Sky Sports Live not loading in Safari (Silverlight issue?)

Discussion in 'OS X El Capitan (10.11)' started by doc88, Jul 11, 2015.

  1. doc88 macrumors newbie

    doc88

    Joined:
    Jul 11, 2015
    #1
    Since installing 10.11 on a mid 2012 retina MBP I've found that the Sky Sports live website no longer loads any video after signing in, while using Safari. Rather than the player loading, the box it's contained in is just white and I get a spinning beachball. Am able to interact with other Safari windows while this is happening.

    Unfortunately I'm not able to test in other browsers as they never worked with Sky Sports live before I installed El Cap.


    Have tried uninstalling and reinstalling flash player and Silverlight and clearing out their respective preference folders too.


    Anyone else having this problem? Would quite like to watch the rest of the cricket!


    Thanks
     
  2. Shirasaki macrumors 603

    Shirasaki

    Joined:
    May 16, 2015
    #2
    Someone noted an "unsafe mode" for plugins. There should be a setting item in safari. I didn't dig into it too much so I am not sure.
     
  3. doc88 thread starter macrumors newbie

    doc88

    Joined:
    Jul 11, 2015
    #3
    There is an option to stop loading plugins to save power but thats not ticked for me and everything I've checked under security for plugins is all set to "allow".

    Have searched through all the preference panes in settings but there's nothing I can find that may help.

    If anyone finds anything I'd really appreciate it!
     
  4. 1madman1 macrumors regular

    Joined:
    Oct 23, 2013
    Location:
    Richmond, BC, Canada
    #4
    I just discovered PAYPAL's website didn't seem to be working for me, evidently they use Silverlight at the login page.
     
  5. Shirasaki macrumors 603

    Shirasaki

    Joined:
    May 16, 2015
    #5
    I have finally found "unsafe plugin mode" option. It just locates at preference pane --> security tab --> Plug-in Settings button. Click that button, and you will know how to enable "unsafe mode" for certain plugins. It can also be set in a site basis, rather than globally.
     
  6. doc88, Jul 11, 2015
    Last edited: Jul 11, 2015

    doc88 thread starter macrumors newbie

    doc88

    Joined:
    Jul 11, 2015
    #6
    Found that and tried but still no luck, same page loads with a white box where the video should be. Spinning beachball after waiting a while.

    Had a look at console and these messages appear when loading the page:
    11/07/2015 19:36:35.624 useractivityd[449]: [SFActivityAdvertiser] ERROR: no XPC proxy, queuing advertisement <642105da 75413e01 d0>
    11/07/2015 19:36:36.491 WindowServer[205]: _CGXRemoveWindowFromWindowMovementGroup: window 0x182 is not attached to window 0x184
    11/07/2015 19:36:40.849 useractivityd[449]: [SFActivityAdvertiser] ERROR: no XPC proxy, queuing advertisement (null)
    11/07/2015 19:36:46.063 com.apple.xpc.launchd[1]: (com.apple.WebKit.Networking.92052D4C-294E-4B1C-B9A5-4D0EA0395285[692]) Service exited with abnormal code: 1
    11/07/2015 19:37:08.703 useractivityd[449]: [SFActivityAdvertiser] ERROR: no XPC proxy, queuing advertisement <642105da 75413e01 d9>
    11/07/2015 19:37:11.135 useractivityd[449]: [SFActivityAdvertiser] ERROR: no XPC proxy, queuing advertisement (null)


    Maybe a problem with the SkySports website conflicting with Safari 9.0 in El Capitan?


    Update: just tried with Amazon prime instant video and the same issue (seems to be isolated to Silverlight)
     
  7. Shirasaki macrumors 603

    Shirasaki

    Joined:
    May 16, 2015
    #7
    So if it is possible to suspect Silverlight for Mac has serious bugs preventing it from working properly?
     
  8. Donfor39 macrumors 6502a

    Donfor39

    Joined:
    Jul 26, 2012
    Location:
    Lanarkshire Scotland
    #8
    Skygo not working either.

    Had to wait for Full Yosemite release thinking it maybe the same with El Capitan betas
     
  9. Donfor39 macrumors 6502a

    Donfor39

    Joined:
    Jul 26, 2012
    Location:
    Lanarkshire Scotland
    #9
    Sky go IS working with IOS9
     
  10. SoyCapitanSoyCapitan macrumors 68040

    SoyCapitanSoyCapitan

    Joined:
    Jul 4, 2015
    #10
    I can't get anything Silverlight to work in Yosemite or El Capitan anyway
     
  11. doc88 thread starter macrumors newbie

    doc88

    Joined:
    Jul 11, 2015
    #11
    Possibly but it was working fine for me in Yosemite. Guess either a problem Microsoft (with a silverlight update) will eventually fix, or Apple (next beta patch) will.

    If anyone comes across a solution in the meantime I'd be very grateful.
     
  12. xlost6 macrumors 6502

    Joined:
    Feb 28, 2011
    #12
    I'm trying to watch a Live Feed on CBS's website and I can't seem to get the video to play. It was working before on Yosemite without Adobe Flash but doesn't seem to be working now that I have EL Capitan Public Beta. It just continues to load and load. I think it has something to do with El Capitan. I can watch movies on Netflix perfectly though.
     
  13. Donfor39 macrumors 6502a

    Donfor39

    Joined:
    Jul 26, 2012
    Location:
    Lanarkshire Scotland
    #13

    Sky won't support until full El Capitan release..not likely to be a workaround during beta's
     
  14. gelie macrumors regular

    Joined:
    Mar 7, 2010
    #14
    yea having the same problems with Tunein and some Fidelity sites. Back to Firefox.
     
  15. Donfor39 macrumors 6502a

    Donfor39

    Joined:
    Jul 26, 2012
    Location:
    Lanarkshire Scotland
    #15
    Viewing via Sky.com workaround for Yosemite/Mavericks/El Capitan beta's

    download firefox set silverlight to always activate.

    I've only tried the with El Captan though should work with other OS X versions.

    viewing via sky.com only or browser version Skygo -no fix yet for Skygo desktop.
     
  16. Donfor39 macrumors 6502a

    Donfor39

    Joined:
    Jul 26, 2012
    Location:
    Lanarkshire Scotland
  17. doc88 thread starter macrumors newbie

    doc88

    Joined:
    Jul 11, 2015
    #17


    Thanks, I'll give this a go later and see how it goes. At the moment struggling with WiFi now in El Cap but that's a different story for a different post!
     

Share This Page