Skype and sleep mode

Discussion in 'iOS Apps' started by Floris, Oct 23, 2016.

  1. Floris macrumors 68020

    Floris

    Joined:
    Sep 7, 2007
    Location:
    Netherlands
    #1
    i think i managed once in the last month or so to put the phone in sleep mode and in my pocket when on skype. Without losing the call. It seems the new versions require the screen to be active. Pressing the sleep button forces the call to end. This was never the case. Is there a setting for this that i cannot find? Am i just unlucky on my phone that it doesnt work?
     
  2. nebo1ss macrumors 68030

    Joined:
    Jun 2, 2010
    #2
    Well i have never tried pressing the button when active on a call but i have no problem receiving calls when in sleep mode.
     
  3. Floris thread starter macrumors 68020

    Floris

    Joined:
    Sep 7, 2007
    Location:
    Netherlands
    #3
    It seems to be a new setting.
    There's a 'integrate call' setting for iOS 10.
    When that's turned on it looks and feels like a facetime call. And that also means skype shows in contacts overview, and when you get a call, you get to pick to decline or pick up. Unlike the normal old setting, which forces skype to go to 'on hold'.

    But the new setting .. if you click sleep, so you can continue a bike ride or a walk, while phones in pocket, it hangs up, the old setting, i can close the screen so to speak, and behaves as the old way. But of course ,you lose the integration features.

    The annoyance of being unable to lock the screen.. is worth turning it off for me.

    sigh, this skype though..
     
  4. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #4
    Interesting. With regular calls the iPhone simply locks the screen when you are in a call using speakerphone or a headset/Bluetooth speaker, yet with the integration to make Skype calls behave like regular calls that aspect of it does't work the same way? Rather poor integration if things aren't consistent. Perhaps just a bug of some sort somewhere (either on Apple's or Skype's side of things).
     
  5. Floris thread starter macrumors 68020

    Floris

    Joined:
    Sep 7, 2007
    Location:
    Netherlands
    #5
    When Skype integrated calls setting is on. It says "Skype call ended..." on the screen, just before it goes black. It doesn't matter if I am on speaker or using the apple earpods. Skype's response to the matter is dead silent as usual.
    I've turned off integration, despite that i really like the choice of 'you have an incoming call, accept, decline', so it doesn't just abruptly put the current one on hold wondering both parties what the heck just happened. Just so i can press the button, and put the phone in my pocket.
     

Share This Page