Skype upgrade failed - now can't install

Discussion in 'Mac Basics and Help' started by Zecchetti, Apr 28, 2012.

  1. Zecchetti macrumors newbie

    Joined:
    Feb 4, 2012
    #1
    Hi all,

    I'm new to Macs and I'm stuck. Please help, thanks in advance.

    I was using skype and a dialogue popped up asking me to upgrade to the latest edition, so I did. Tried to install the file that saved on my desktop, but it said:

    "An older item named “Skype” already exists in this location. Do you want to replace it with the newer one you’re moving?"

    I said yes, entered my password, then a failure message popped up saying:

    "The operation can’t be completed because some items had to be skipped. For each item, choose File > Get Info, make sure “Locked” is deselected, and then check the Sharing & Permissions section. When you are sure the items are unlocked and not designated as Read Only or No Access, try again."

    I've no idea what to do here... and why did this message pop up? Maybe because I didn't quit skype before I tried to upgrade, but I thought it would close it automatically.

    I then tried again and this time instead of opting to replace files I said keep them, so then it installed but the result was that I now had 2 skypes! One was "Skype" and the other was "Skype 2". I just wanted to delete all traces of skype and start over, so I went to my applications folder and dragged and dropped skype into the trash folder - that deleted "Skype 2", but Skype 1 is still there and I don't know how to get rid of it. I am using Lion and when I go into that new iOS style view of all programs, skype 1 is still there, but when I go into Finder, it's nowhere to be seen.

    I then tried installing the new Skype again, but it still says there is already a Skype on my system and that the filed can't be overwritten (i.e. the same dialogue mentioned above).

    Please help!!
     
  2. Zecchetti thread starter macrumors newbie

    Joined:
    Feb 4, 2012
    #2
    Can someone please help? The answer might be very easy for you experts out there - just a few lines!

    Thanks a lot
     
  3. techzone707 macrumors newbie

    Joined:
    Apr 30, 2011
    Location:
    Canada
    #3
    Find Skype(s) (Open Finder and Search), put it(them) in the trash and empty it.
    Go to the Skype site and install,
    Dont worry everything is saved you wont loose anything.
    Hope this helps,
    Tech
     
  4. Zecchetti thread starter macrumors newbie

    Joined:
    Feb 4, 2012
    #4
    Thank you

    I already sussed it. I tried simply trashing it but it still didn't fully uninstall. So I located the system files of skype and deleted those, which solved the problem.
     
  5. SDRacerR1 macrumors member

    Joined:
    Aug 28, 2009
    #5
    I have/had the same problem. It happens to every new app you want to "replace" that is already in the applications folder.

    For me, and not sure if this is your case, but I am not running on the default administrator account. I user my account as a limited user, then usually have to "authenticate" with the admin account. I heard its safer that way.

    For some reason, I gets confused when this happens. So you can do a couple things...

    1. Delete the app, then install the new version, which is sorta tedious.

    2. Open Finder, right click on the applications folder, Get Info. Under sharing and permissions, click on the lock. Enter your admin information. Then, add whatever non admin account you are working on, and allow it to have read and right permissions.

    This solved the problem for me, I thought in SL, that you didnt need to do this, so I dont know if its something new in Lion.

    Still dont understand either, if you enter the Admin information why is wont let you "replace" the app, but thats what worked for me.
     
  6. techpixie macrumors newbie

    Joined:
    May 27, 2012
    #6
    Solved by using main admin account on computer

    I had the same problem and discovered it was because I was trying to install from a user account that was not the first/main user account on the computer (though it did have read & write & admin permissions). When I switched over to the main admin account and did the install, it worked perfectly.
     
  7. pitman macrumors newbie

    Joined:
    Jul 18, 2002
    #7
    trash

    Had the same problem. I unlocked the file and had read/write access but the new version still wouldn't install. So I trashed the old version and installed the new one. No problem. Contacts still there, account balance, etc.
     

Share This Page