Skype Voicemail Timer - No option in OSX, only windows?!?

Discussion in 'Mac Apps and Mac App Store' started by Sean Dempsey, May 14, 2010.

  1. Sean Dempsey macrumors 68000

    Sean Dempsey

    Joined:
    Aug 7, 2006
    #1
    I have skype going, I pay for both a skype in and out number, and I want it to go to voicemail even if I am online.

    Right now, it just rings and rings and never goes to voicemail unless I decline the call or shut down the application. Which means if I am not there to answer, it just rings and never goes to voicemail.

    On the skype website, it says to go to "Tools > options > calls > voicemail" to set the number of seconds before it goes to voicemail.... but that option doesn't exist in the OS X skype client!!!

    Does anyone know anything about this?
     
  2. iammike1 macrumors 6502a

    iammike1

    Joined:
    Oct 25, 2007
    Location:
    Columbia MD
    #2
    I know I have the same exact issue...that's about it. Haven't figured out how to fix it.
     
  3. Sean Dempsey thread starter macrumors 68000

    Sean Dempsey

    Joined:
    Aug 7, 2006
    #3
    I figured it out. It's really lame.

    Go to your Preferences > Calls

    Click the checkbox for forwarding, which will let you type in a amount of seconds after which it forwards. Leave the forwarding box blank.

    As you checked the forwarding checkbox, the voicemail option down below slides into view and you can now check the box for sending the call to voicemail.


    If you don't have the forwarding box checked, you can't see the voicemail box. It's the most un-intuitive thing I've ever seen.
     
  4. iammike1 macrumors 6502a

    iammike1

    Joined:
    Oct 25, 2007
    Location:
    Columbia MD
    #4
    Hmmm, mine doesn't behave this way. I can see the Voicemail area the same no matter if Forwarding is checked or not.

    Also, the checkbox for Forwarding an unanswered call to Voicemail has been checked the whole time.
     
  5. Belfurious macrumors newbie

    Joined:
    May 31, 2010
    #5
    I have found the solution! Steve Madsen over at Light Year Software posts it here:

    http://lightyearsoftware.com/blog/2010/03/voicemail-problems-with-skype/

    Here's the quote:

    "Unanswered calls not going to voicemail?

    Quit Skype. Open ~/Library/Application Support/Skype/your-user-name/config.xml in a text editor. Look for:

    <Call>
    ...
    <NoAnswerTimeout>10</NoAnswerTimeout>
    ...
    </Call>
    The number is the delay, in seconds, before Skype will do something with the call. If this is missing, Skype won’t send the call to voicemail."

    Worked like a charm for me.
     
  6. DawnEMc macrumors newbie

    Joined:
    Mar 26, 2012
    #6
    This worked

    This is the solution that worked for me.:)

    As far as I can tell, the important part is to leave the forwarding numbers blank in "set up forwarding" and to leave "Send to voicemail" selected in the Preferences/calls window.

    Not sure how or why, but it worked fine.

    -Dawn

     

Share This Page