SL Dimming Screen itself

Discussion in 'MacBook Pro' started by Magaman, Sep 13, 2009.

  1. Magaman macrumors regular

    Joined:
    Aug 14, 2009
    #1
    Alright well I'm experiencing a rather strange bug and at first I thought I was going nuts. For some reason on my my MBP 2008 the screen dims itself. And auto dimming is off! I keep auto dimming off when plugged in, and while working all of a sudden the screen will dim a few ticks. I then have to F2 them back to full. I never had this issue until I installed SL, I did a clean instal BTW. Anyone else having this issue?
     
  2. earth.mark.two macrumors newbie

    earth.mark.two

    Joined:
    May 23, 2009
    #2
    So you turned off Auto Adjust in the Displays tab of Sys. Preferences? Other than that, I don't see any reason why it would be doing this. I would say take it back, it might be a defective model, and they'll replace it or show you how to fix it. Mine was doing the same, but as soon as I turned off Auto Adjust, it stopped.

    Good luck.
     
  3. SimonJ macrumors regular

    Joined:
    Jul 11, 2008
    Location:
    Czech Republic
    #3
    I don't think that's a defect. My uMB (not pro :-( ) has been doing it too. Seems like a bug.
     
  4. Freyqq macrumors 68040

    Joined:
    Dec 13, 2004
    #4
    You might be moving your hands over the light sensor, making it think it's darker in the room and dimming the display. You can turn this off i think.
     
  5. crazzyeddie macrumors 68030

    crazzyeddie

    Joined:
    Dec 7, 2002
    Location:
    Florida, USA
    #5
    Wirelessly posted (Mozilla/5.0 (iPod; U; CPU iPhone OS 3_1_1 like Mac OS X; en-us) AppleWebKit/528.18 (KHTML, like Gecko) Version/4.0 Mobile/7C145 Safari/528.16)

    The light sensor on the uMBPs is next to the camera, so I doubt his hands are causing the issue. It also wouldn't explain why it's happening when the option is turned off.
     
  6. vapormike macrumors newbie

    Joined:
    Sep 6, 2009
    #6
    With the newer mac screens they have dynamic dimming features built-in to save energy. Its triggered by the light sensor located by the camera of the macbook. I'm not sure if it can be disabled. The dim feature in the energy saver does not refer to this.
     
  7. earth.mark.two macrumors newbie

    earth.mark.two

    Joined:
    May 23, 2009
    #7
    The setting to disable this is in System Preferences---->Displays--->Colours. It says something like 'Automatically Adjust Brightness as Ambient Light Changes. It certainly can be disabled, I just did it myself a few days ago :)
     

Share This Page