SL kills Laserjet 2015 duplex printing

Discussion in 'macOS' started by monokakata, Sep 9, 2009.

  1. monokakata macrumors 68000

    monokakata

    Joined:
    May 8, 2008
    Location:
    Hilo, Hawai'i
    #1
    I'm putting this here rather than in Peripherals, since I think it's a Snow Leopard issue, meaning that I don't think there's anything wrong with my printer or its connection.

    Laserjet p2015dn. Always printed duplex when requested, although I can't say for certain that 10.5.8 worked, since I don't print duplex regularly.

    After SL, I had only the "Manual Duplex" option, and nothing I could do would return my standard Duplex option. I reinstalled, reset the printer firmware, etc. etc. Every place that there's a duplex option, it's checked.

    Everything else about the printer is fine -- it sits out on the network and prints happily. I have not made a USB connection to see if that makes a difference.

    Anybody else?

    I decided to post here before seeing what might happen if I reinstall the 10.5 package from HP (their site says -- don't do it).
     
  2. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #2
    If it worked before SL and now it doesn't. It's not a firmware issue but rather a driver issue. The supplied SL printer driver does not have this functionality for your printer.

    You need to contact HP on when (or if) they'll have updated printer drivers.
     

Share This Page