SL spotlight trouble

Discussion in 'macOS' started by funkahdafi, Mar 22, 2010.

  1. funkahdafi macrumors 6502

    Joined:
    Mar 16, 2009
    Location:
    Planet Earth, Old World
    #1
    Hi there,

    I've been experiencing some really bad Spotlight behavior and I tried almost anything to solve it, but to no avail.

    I first noticed the troubles when I found out that it wouldn't show me any search reasults for newly added files anymore. So I started investigating. Tried almost all of the suggested solutions out there in the forums. Resetting the index, deleting the index, removing drives from the indexing process one by one, resetting again, deleteing again... no matter what I do, I always end up with a dead Spotlight a couple of hours or days after the last reset.

    What I can tell is that once I reset/re-index, I always have at least one "mdworker" and "mdworker32" process running. And for as long as they run, everything seems fine. But then after a while (usually a couple of hours after the last manual re-index) all mdworker processes just disappear. And once they are gone, I start all over again, because that's the moment Spotlight stops indexing new files.

    I searched my logs but I usually don't find any entries that would suggest a crash or abnormal exit of the mdworker processes. They disappear silently.

    My only solution right now is to almost daily do a "mdutil -E -a", which helps for a couple of hours or sometimes even a day, before I have to do that all over again.

    So basically Spotlight has become useless to me, and after all the hours I already spent researching and troubleshooting and trying, I am willing to give up and do a clean install of my machine - which would be sad.

    Maybe you guys can come up with some more troubleshooting and help me get this fixed, before I throw the towel.

    Thanks

    (oh - I forgot to mention that I also tried re-applying the 10.6.2 upgrade combo, but that didn't help either).
     
  2. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #2
    I guess it has to be asked, since I didn't see where you mentioned it, but did you repair permissions?
     
  3. funkahdafi thread starter macrumors 6502

    Joined:
    Mar 16, 2009
    Location:
    Planet Earth, Old World
    #3
    yes, I did :) and since I guess the next question will be whether I repaired the disk: yes, i did (no errors) :)
     

Share This Page