Sleep delay

r23w

macrumors member
Original poster
May 9, 2008
46
0
I have an early 2011 MBP 15". Everytime I use the hotkey to sleep or do it from the apple menu it takes 30 seconds for it to sleep. This is with no programs running, no sharing prefs enabled, and nothing out of the usual going on in activity monitor. I reset the PRAM and that didn't do anything.

Could this be a disk issue? I do have a self installed drives, a SSD running lion.

Any ideas on a quick fix?
 

samac92

macrumors 6502a
Feb 18, 2008
537
90
The delay is usually your Mac writing the contents of your ram to the drive, in case of your battery running out whilst it's in sleep mode.

in terminal type

sudo pmset hibernatemode 0
this will turn this feature off. Keep in mind if your MBP runs out of battery while it is asleep you will lose your state as the contents of the memory will not be on the drive.

to switch it back to the MBP's default setting:

sudo pmset hibernatemode 3
 

mikeo007

macrumors 65816
Mar 18, 2010
1,373
122
How much RAM do you have? It's likely that OSX is writing your RAM contents to the hard drive for deep sleep or hibernate mode. It does this every time you put your computer to sleep.

Edit: beaten by a minute. I believe you want to use sudo pmset -a hibernatemode 0
The -a makes sure it applies to all power profiles.
 

falterego

macrumors 6502
Dec 28, 2008
280
0
Southern California
I have a 2011 MacBook Air with 4GB memory that has this same issue. 30-40 seconds to go into sleep. I have a second MBA, same spec that takes virtually no time to sleep. Neither has had the hibernate command run.

The first machine that has the sleep delay does not wake up from sleep using USB keyboard/mouse of the Magic Mouse (yes, I have the "allow bluetooth devices to wake computer" setting enabled)

This is a big problem for my users who have a BookArc stand and external keyboard/mouse/monitor. Any help would be GREATLY appreciated.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.