Sleep image problem

Discussion in 'macOS' started by joeyboyyy91, Apr 17, 2011.

  1. joeyboyyy91 macrumors member

    Joined:
    Aug 20, 2010
    #1
    Today I was using disk inventory x to see how my new SSD is looking, and I noticed a large 4GB document file called sleepimage.

    I googled it, found out what it was, safely deleted it through terminal, and read up about what it is and what it does. Turns out it is supposed to be deleted after the computer wakes up, but obviously its not doing that anymore. I repaired disk permissions and its still not deleting it like it should. If anyone could shed any light onto this i would greatly appreciate it.

    Thanks in advance.
     
  2. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #2
    Did you change the hibernatemode prior to deleting the sleepimage file?

    You'll need to execute
    sudo pmset -a hibernatemode 0
     
  3. joeyboyyy91 thread starter macrumors member

    Joined:
    Aug 20, 2010
    #3
    Yeah I have tried switching the sleep modes.

    Do you think resetting pram and smc will help?
     

Share This Page