Sleep Mode, Cursor Still Seen

Discussion in 'MacBook Pro' started by Classiclays, Sep 10, 2013.

  1. Classiclays macrumors member

    Joined:
    Feb 28, 2012
    #1
    When I put my computer to sleep mode manually on my rMBP, the cursor still appears on the screen with a completely black (lit) background. The Apple light on the back is still on so the computer isn't really off.

    Is this a common problem and is there a potential solution?
     
  2. Classiclays thread starter macrumors member

    Joined:
    Feb 28, 2012
  3. Classiclays thread starter macrumors member

    Joined:
    Feb 28, 2012
  4. comics addict macrumors 6502a

    Joined:
    Feb 16, 2013
    #4
    Could you please elaborate a little bit more? It sounds a awful lot like an issue I experience from time to time on my cMBP 13".
     
  5. Classiclays, Sep 18, 2013
    Last edited: Sep 18, 2013

    Classiclays thread starter macrumors member

    Joined:
    Feb 28, 2012
    #5
    Sure, and thanks for responding.

    So it actually seems the problem is related with putting the computer to sleep. Now, when I close the lid of my computer (without manually pressing the sleep button as before), the screen remains lighted with a black background and the cursor is visible.

    After a minute (or two), the screen eventually turns fully black like it's supposed to.

    I turned off my laptop, turned it back on, and tried to replicate the problem for a picture, but it went immediately to sleep. This probably means that after "continued use" (don't know the proper term but I'm sure you guys know what I mean), it exacerbates.

    Would a PRAM reset work? I believe there's also another reset I can use but don't remember what it's called.

    Seems that another person posted same problem on Apple Discussions: https://discussions.apple.com/thread/5273980?start=0&tstart=0

    Edit: Did PRAM reset. Will update if it works out. However, this seems like a problem that a lot of people have had and Apple has not addressed. Similar variants have occurred since 2009 I believe so not much to do at this point unless someone here knows something.
     
  6. Classiclays thread starter macrumors member

    Joined:
    Feb 28, 2012
    #6
    Problem still occurs after the reset.

    My Applecare expired probably a month ago. I have an additional one year through American Express.

    Would I be charged if I brought it into store to try to get it fixed? I know American Express will cover repair costs but I believe Apple charges for a diagnostic test?
     
  7. comics addict macrumors 6502a

    Joined:
    Feb 16, 2013
    #7
    So sorry for responding so late but I lost track of this thread after my last post. It's a bummer that you haven;t being able to work out a solution for this problem. But by reading your description of the issue it's exactly what I experience,even though, in the last few months I have hardly experience said issue. Just wanted to confirm because it strikes me that you were ambiguous about it but does the screen has a black background with a cursor visible if you open the lid waking the computer from sleep ? Because that's how I have always experienced this issue.
     
  8. Classiclays thread starter macrumors member

    Joined:
    Feb 28, 2012
    #8
    Yep. I now experience it when I close the lid and open it up again within two minutes AND when I put it to sleep manually.
     

Share This Page