Sleep Mode problem in Snow Leopard

Discussion in 'macOS' started by Graig, Sep 18, 2009.

  1. Graig macrumors 6502

    Graig

    Joined:
    Aug 23, 2009
    Location:
    Vancouver, BC
    #1
    Sleep Mode does not seem to be working automatically in Snow Leopard. It sleeps when activated from the Apple Menu but not when set to sleep in Energy Saver Preference Pane. The screen dims, goes black but the computer does not seem to sleep nor does the hard drive spin down. Anyone else having a problem like this? It was working fine in Leopard (just noticed this problem now, but have had Snow Leopard installed for a couple of weeks and never noticed it)
     
  2. tzilske macrumors newbie

    Joined:
    Jul 7, 2008
    Location:
    Philadelphia, PA
    #2
    I have the same issue on my Mac mini and macbook pro, both new models. While initially they would go to sleep, I've noticed over the last few days that they don't. When I put them to sleep manually, they turn on again to broadcast their services for wake on wireless but then never go back to sleep. This is not so bad on the macbook but annoying on the mini since it's on basically all the time now.
     
  3. SolRayz macrumors 6502a

    SolRayz

    Joined:
    Jul 5, 2007
    Location:
    Ft. Lauderdale
    #3
    I have the same problem. I tried repairing permissions and a SMC reset, which seems to work initially, but after a few days it fails to sleep again.

    Hopefully this is addressed in 10.6.2
     
  4. Moof1904 macrumors 65816

    Joined:
    May 20, 2004
    #4
    Same here with Mac Pro 2008

    Clean install of SL on my Mac Pro. I can make my Mac sleep manually but the sleep settings in the energy saver control panel aren't working.
     
  5. spetykowski macrumors member

    Joined:
    Sep 1, 2007
    #5
    Check out this thread for some help. There are no official fixes for this issue, but some people have had luck with a few differnt solutions posted on that thread.... That being said, I currently use the app. Please Sleep, to force the computer to sleep for the time being.

    Here's to 10.6.2 *fingers crossed*:rolleyes:

    Code:
    http://forums.macrumors.com/showthread.php?t=776329
     
  6. Meiss macrumors newbie

    Joined:
    Dec 17, 2009
    #6
    Sleep Mode Problem in Snow Leopard-> Location!

    I tried all the possible solutions in this forum (except for "PleaseSleep"), but for me none of them worked. However, I figured out what was causing my MacBook Pro (2008) to not sleep (with the lid open) under 10.6.2: I had turned on the "Set Time Zone Automatically Using Current Location".

    This this unchecked, my laptop goes to sleep as it should. A symptom that I noticed in console were some messages from ntpd (the network time daemon): it was saying "No route to host 17.151.16.21)." Perhaps that has to do with location services.
     

Share This Page