sleep mode / screen issues

Discussion in 'MacBook Pro' started by cyberthom, May 9, 2011.

  1. cyberthom, May 9, 2011
    Last edited by a moderator: May 9, 2011

    cyberthom macrumors newbie

    Joined:
    Sep 14, 2010
    #1
    Sorry if this is a known issue but i wasn't sure what to search for. My 13" 2011 MacBook Pro every so often locks up when i try to wake it from sleep mode. Sometimes the screen is just black but the keyboard is illuminated in which case i can close and re-open the laptop and it works fine. Other times the screen looks like this (see attachment) and there's no way of making it usable again without a hard reset (pressing the power button for a few seconds).

    Any advice? I know i should probably call Apple Care but was wondering if other people have had the same issues and how Apple handled it - I need the laptop for work so can't just wait a week for a repair.
     

    Attached Files:

  2. discounteggroll macrumors 6502

    discounteggroll

    Joined:
    Aug 6, 2006
    Location:
    Greenwich, CT
    #2
    I suspect faulty LCD display, but I would try connecting it to an external monitor to see if the issue persists on that. I would not consider a faulty/loose connection as this is an intermittent problem
     
  3. McGB81, May 9, 2011
    Last edited by a moderator: May 9, 2011

    McGB81 macrumors newbie

    Joined:
    May 9, 2011
    #3
    I had this exact same problem OP on my 2011 15" MBP.

    Have you recently installed AirDisplay?

    After looking around on this and other forums I found that uninstalling it fixed the problem completly and perminantly.

    Hope this helps
     
  4. McGB81, May 9, 2011
    Last edited by a moderator: May 9, 2011

    McGB81 macrumors newbie

    Joined:
    May 9, 2011
    #4
    As I mentioned in your other post, I had this exact same problem with my 15" 2011 MBP.

    Do you have AirDisplay installed?

    Searching on this and other forums I found out this may be causing it and uninstalled. Everything working fine now.

    Hope this helps you out.
     
  5. cyberthom thread starter macrumors newbie

    Joined:
    Sep 14, 2010
    #5
    I don't have AirDisplay installed actually but it sounds like it could be a software issue - maybe ill just wait until the next osx update and see if the issue persists. the 13" model has integrated graphics only and the drivers seems a bit premature (e.g. caused problems with civ5).
     
  6. McGB81 macrumors newbie

    Joined:
    May 9, 2011
    #6
    Sorry couldn't have been more help. I know it was very frustrating for a few days having to do a hard re-start everything it went to sleep by itself.

    My only other advice would be to check for the latest osx updates (there were 2 mbp ones last week) or if its a recent problem (i.e. not from when u first pruchased) check recent applications you've installed. If it's only just started happening I would think it's probably a software issue that can be resolved fairly quickly.
     
  7. cyberthom thread starter macrumors newbie

    Joined:
    Sep 14, 2010
    #7
    installed the efi firmware update - fingers crossed
     
  8. darkeartg macrumors regular

    Joined:
    Jan 27, 2011
    #8
    This just happened to me, but it has never in the past (got the 2011 the first day it came out). Prob a software issue, not too worried about it,
     

Share This Page