Sleep takes 30 seconds on Intel iMac

Discussion in 'macOS' started by cb31, Oct 4, 2006.

  1. cb31 macrumors member

    Mar 13, 2005
    Has anyone seen anything similar to my problem? When I hit the sleep option on the blue apple sign nothing happens for about 30 seconds and then it sleeps instantly. Waking up is instantaneous.

    My machine is an Intel iMac with 1.5Gb RAM. Up until a few weeks ago it slept the instant I selected the option, and just after the reboot when I installed 10.4.8 it slept properly but since then it is back to the slow sleep.

    I have tried closing all the apps down before sleeping but that made no difference. Anything else I can try?
  2. rdowns macrumors Penryn


    Jul 11, 2003
    Have you tried repairing permissions?

    Launch Disk Utility which you will find in the Utilities folder in your Applications folder.
  3. Mustafa macrumors regular

    Jun 23, 2003
    Shenfield, Essex, UK
    Try the Sleep shortcut -- Opt+Cmd and tap the eject key. Actually this is a much more convenient way of putting your Mac to sleep anyway, IMHO.
  4. deebster macrumors 6502

    Oct 21, 2004
    Olde Englande
    Try putting it to sleep immediately after rebooting, so only the barest number of apps are open.

    You might want to post a screenshot of Activity Monitor's window after rebooting so we can see exactly what apps and processes are running.

    Sounds to me like you've got something going on in the background that is eating the CPU. MenuMeters is a free app that will allow you to have a CPU meter on the Menubar.
  5. macrumors 6502a

    Jul 17, 2002
    Bay of Fundy
    I've had the same problem with one of my systems since I installed 10.4.8

    It goes into pseudo-sleep after you initiate the command, but then it's at least 20-40 sconds before it actually spins everyting down and goes to sleep. I've repaired permissions, checked apps running, tried with and without CDs in the drive, etc. etc.

    Now the system isn't as new as yours (iMac G3 400MHz) but it seems to be the same issue
  6. Scottyk9 macrumors 6502a

    Jun 18, 2004
    My MBP has done this ever since I got it (pre-10.4.8). Way slower getting to sleep than my powerbook. Nothing has seemed to influence it, I thought it was just from the intel switch.
  7. cb31 thread starter macrumors member

    Mar 13, 2005
    That sounds just the same symptoms, except mine is 30 seconds every time.

    The weird thing is that after the 10.4.8 upgrade it was fixed, or so I thought.

    I have checked processor usage and it is nearly always idle, I usually run activity monitor in the dock with cpu usage displayed. I will do some process listings in terminal and see if I can spot anything.

    I will also try the shortcut key but don't expect that to make a difference.
  8. Marioz macrumors member

    Aug 6, 2006
    Rivarolo, Italy

    Sorry but this is quite obvious. In your PB you had a fisical bkp battery to keep memory on if you took out your main laptop battery. MBP uses to save your RAM on the disk as the small bkp battery does not exist any more.
    I agree w/h you, anyway, that such a system of working it is not pleasant at all. In my MBP I deactivated "hybernation".

Share This Page