"Sleep" vs. "Put Display to Sleep"

Discussion in 'OS X El Capitan (10.11)' started by stanman64, Jan 25, 2016.

  1. stanman64 macrumors 6502

    stanman64

    Joined:
    Jul 9, 2010
    Location:
    Indianapolis, IN
    #1
    Are the hot corner action "Put Display to Sleep" and the Apple Menu shortcut "Sleep" separate functions?

    I understood "Put display to Sleep" as it would shut off the screen and keyboard backlights to conserve energy, but not put the actual CPU into sleep. However whenever I use "Put Display to Sleep," I am prompted to enter my passphrase upon waking my Mac, as if it had gone to sleep.

    Is this how it is supposed to be? It would be much better if they were separate...
     
  2. Nermal, Jan 25, 2016
    Last edited: Jan 27, 2016

    Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #2
    Bizarrely, newer machines will, by default, go into full sleep a few seconds after going into display sleep (cutting off network connections and other nasty things). There is also an option in Energy Saver called "Present computer from sleeping automatically when the display is off" which may help. Failing that, it should be possible to configure it by using the pmset terminal command, but I'm not sure of the exact syntax required.

    (Edited for clarification and to match latest version of OS X).
     
  3. stanman64 thread starter macrumors 6502

    stanman64

    Joined:
    Jul 9, 2010
    Location:
    Indianapolis, IN
    #3
    Bummer. That seems odd. Hopefully someone else can provide the command line. I'll do some deeper Googling tomorrow to see if I can find it somewhere. Thanks for the reply!
     
  4. jgelin macrumors 6502a

    jgelin

    Joined:
    Jul 30, 2015
    Location:
    St Petersburg, FL
    #4
    Here is some more reading on the differences between sleep, display sleep, and their functions.
    https://support.apple.com/en-us/HT201714
    Also the newer laptops which were made in 2013 have a deep sleep feature which can retain 99% battery power for 30 days.
     
  5. stanman64 thread starter macrumors 6502

    stanman64

    Joined:
    Jul 9, 2010
    Location:
    Indianapolis, IN
    #5
    Thank you for the link, but unfortunately it doesn't address the problem I am having. Apple's own website seems to be out of date, showing (and describing steps of) a screenshot of Mountain Lion settings, since which have changed. No longer is there dual sliders to separately adjust display sleep time and full computer sleep time.
     
  6. adrianlondon macrumors 6502

    Joined:
    Nov 28, 2013
    Location:
    Switzerland
    #6
    In preferences, tick "Prevent computer from sleeping automatically when the display is off". You can now turn off the display without the laptop sleeping.

    Closing the lid still causes the laptop to sleep, which is what I want.
     
  7. RadioGaGa1984 Suspended

    RadioGaGa1984

    Joined:
    May 23, 2015
    #7
    Check your security and privacy in preferences. Is require password checked?
     
  8. bent christian Suspended

    bent christian

    Joined:
    Nov 5, 2015
    #8
    No, they don't if you have your power settings configured to prevent sleep.

    Also, you don't need to waste a hot corner to put the display to sleep. A keyboard shortcut exists by default: control-shift-eject (or power button if you do not have eject)
     
  9. Partron22 macrumors 68000

    Partron22

    Joined:
    Apr 13, 2011
    Location:
    Yes
    #9
    For those who use non-Apple keyboards, a little AppleScript service can do the job:
    Code:
    do shell script "pmset displaysleepnow"
    Assign it to whatever key combo you want in keyboard prefs.
     
  10. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #10
    Correct, but I meant by default (and will edit my post to clarify this). While my previous machine had two sliders in Energy Saver (one for display sleep and one for system sleep), my 2015 MBP only has a single slider, plus a box for "Prevent computer from sleeping automatically when the display is off". Despite that, I've had to use pmset in the past for some reason (that may have been under 10.10 - do you know whether the "prevent sleeping" box was present in 10.10?)
     
  11. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #11
    I think its because the current chipsets from Intel go into low power mode on their own and so a full sleep setting in OS X is not needed.

    Basically, we have less choice because of the advances in power consumption at the chip level. That's my opinion based on various stuff I read when I was searching around on why there was only one slider on my new iMac
     
  12. stanman64 thread starter macrumors 6502

    stanman64

    Joined:
    Jul 9, 2010
    Location:
    Indianapolis, IN
    #12
    This option is only available under "When Connected to Power Source" for portable Macs.
    --- Post Merged, Jan 28, 2016 ---
    Yes, I do have a password set up through Security & Privacy, but there is no option under Energy Saver preferences that allows me to toggle requiring a password.
    --- Post Merged, Jan 28, 2016 ---
    I find the hot corner more convenient, but that's just personal preference. Either way, I am still prompted to enter my passphrase upon wake.
    --- Post Merged, Jan 28, 2016 ---
    This could be the culprit. I used to be able to use a hot corner to put the display into sleep, but leave the system running on my '12 MBP. It would not prompt me for my system passphrase when I "woke" the screen back up. However, Menu > Sleep would put the whole system into sleep and lock my MBP. This is what I want. Something definitely changed though.
     
  13. RadioGaGa1984 Suspended

    RadioGaGa1984

    Joined:
    May 23, 2015
    #13
    That is why it's asking for the password when you wake it back up. There is no option is energy saver only in security and privacy.
     
  14. stanman64 thread starter macrumors 6502

    stanman64

    Joined:
    Jul 9, 2010
    Location:
    Indianapolis, IN
    #14
    The password is supposed to be for when you are powering up/logging in/waking from sleep, not for just when you want to turn the display off. So if I just put my display to sleep, the system should stay active and not lock me out. At least that is how it used to be.
     
  15. RadioGaGa1984 Suspended

    RadioGaGa1984

    Joined:
    May 23, 2015
    #15
    Yea that's not how it's been working if I have the password on it will ask for it when waking from display sleep and system sleep.
     
  16. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #16
    Aha! That would explain why I've had to use pmset to get everything working in the past. I think "sudo pmset -a sleep 0" is the command that I've used, although that will stop the system from ever sleeping (rather than only applying to hot corners).
     
  17. stanman64 thread starter macrumors 6502

    stanman64

    Joined:
    Jul 9, 2010
    Location:
    Indianapolis, IN
    #17
    Maybe Apple will fix/bring back this feature in a future update! One can only hope...
    --- Post Merged, Jan 28, 2016 ---
    Must be! I'll have to pass on the never sleep terminal command though. I'd prefer not to have my bag catch fire..
     
  18. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #18
    It does still sleep when you close the lid. I forgot about that case when I said "never" :)
     
  19. stanman64 thread starter macrumors 6502

    stanman64

    Joined:
    Jul 9, 2010
    Location:
    Indianapolis, IN
    #19
    Will it sleep with Apple Menu > Sleep too?
     
  20. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
  21. stanman64 thread starter macrumors 6502

    stanman64

    Joined:
    Jul 9, 2010
    Location:
    Indianapolis, IN
    #21
    Entered the command in terminal. Still prompting for password no matter what I do. At this point, oh well.
     

Share This Page