Sleep/Wake Issue

Discussion in 'MacBook Pro' started by pfeez, Aug 12, 2015.

  1. pfeez macrumors newbie

    Joined:
    Aug 12, 2015
    #1
    Hi everyone, first time poster in order to try and shed some light on a problem I'm having.

    I went on holiday for a week and left my Macbook Pro at home and since getting back it's started behaving oddly during sleep/wake up.

    When I close the lid, it sleeps, but when I open it up, the display is all garbled and shows lots of very small versions of the desktop, which is still working as I can move the mouse around and see the dock increase in size. (See photo). If I power off, then on again it's returns to normal. I can also put it to sleep again via the keyboard shortcut, then reawaken it via hitting the return key and the screen is back to normal.

    Oddly, if I put it to sleep via the keyboard shortcut and then wake it up again, it's fine. But if I sleep it via the keyboard and then close the lid, when I open it, the problem returns.

    Any ideas? It must be something to do with the lid right as the sleep/wake function has no issues from the keyboard?

    Thanks

    Screen Shot 2015-08-12 at 14.16.40.png
     
  2. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #2
    Honestly that looks like a Logic Board/GPU failure, but it's a little weird how the issue is only apparent on sleep/wake.

    Is the HDD OK? Anything other than passed means it's a faulty HDD. You can download SMART Utility here.

    Can you try a volume verification in Disk Utility if SMART Utility comes out as passed?

    Does it still have AppleCare?
     
  3. pfeez thread starter macrumors newbie

    Joined:
    Aug 12, 2015
    #3
    Thanks for getting back to me. Hard Drive seems OK. SMART said it passed and Disk Utility permission threw this back

    User differs on “private/var/db/displaypolicyd”; should be 0; user is 244.
    Group differs on “private/var/db/displaypolicyd”; should be 0; group is 244.

    ...which I've now repaired. I googled it and found someone who was having an issue with that same permission not sending a signal to his monitor. Said it was fixed with the permissions repair but appears again at each reboot. Might not be related but now I've repaired it I can see how it goes.

    No applecare sadly. My initial thought was logic board too but it seems too specific. It was second hand but had just had a new logic board put in and larger HDD so I'd be surprised if the boards gone. Added to that, I'm able to use it fine apart from the wake issue and when I opened the lid just now, the problem didn't occur.

    ??? Any other help appreciated.
     
  4. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #4
    If it seems OK now, a volume/permissions repair might have done the trick. Volume corruptions cause Macs to exhibit awfully strange behaviour, so with any luck you won't have the problem again.

    Other things you could try if the problem reoccurs would be:

    - Reset NVRAM/SMC
    - Wipe/reinstall OS X
     
  5. pfeez thread starter macrumors newbie

    Joined:
    Aug 12, 2015
    #5
    After the repair, just tried closing the lid, letting it sleep and then waking it again. Problem didn't occur. I'm hoping it was something to do with that permission but as I said in my last post, even before I did that the problem didn't happen so who knows what's going on. Will come back if issue persists again.
     
  6. mactactic macrumors regular

    mactactic

    Joined:
    Sep 27, 2010
    Location:
    Seal Beach CA , Campbell CA , London UK
    #6
    Reseat the ram and re start , might be bad ram
     
  7. pfeez thread starter macrumors newbie

    Joined:
    Aug 12, 2015
    #7
    Thanks for your replies guys. It happened again today. I ran the Apple Hardware Diagnostic, and did the short and long scans and it didn't find any issue with the logic board or memory.

    If I were to reseat the RAM, how would I go about that?
     
  8. Spink10 macrumors 601

    Spink10

    Joined:
    Nov 3, 2011
    Location:
    Oklahoma
    #8

Share This Page