Sleep wake keyboard freeze

Discussion in 'OS X El Capitan (10.11)' started by Serban, Oct 15, 2015.

  1. Serban, Oct 15, 2015
    Last edited: Oct 15, 2015

    Serban Suspended

    Joined:
    Jan 8, 2013
    #1
    after a while of sleep when i wake my mac , i can't use my keyboard to log in
    this occurs on my 5k imac but i have a friend and even on a macbook happen
    i thing they need to fix this
     
  2. eneisch macrumors 6502a

    Joined:
    Jul 11, 2008
    #2
    Having the same issue with my macbook pro using wireless keyboard. MacBook Pro built-in keyboard works fine. When waking from sleep keyboard is extremely slow to respond, typing lags and sometime types multiple of the same key press. Searching google revealed that others are also experiencing this problem. Hopefully will be fixed in 10.11.1
     
  3. GrumpyTrucker macrumors 6502a

    Joined:
    Jun 1, 2014
    #3
    Same here but also - after using it to wake the iMac - the mouse stops working too. So I'm stuck with no working Bluetooth accessories at all and have to resort to hard restart of the Mac. Happening about 1 in 5 times it comes out of sleep.
     
  4. RednBlue macrumors member

    RednBlue

    Joined:
    Dec 17, 2013
    Location:
    Reading UK
    #4
    Turn sleep off until Apple come up with a fix (in System preferences /energy saver)
     
  5. eneisch macrumors 6502a

    Joined:
    Jul 11, 2008
    #5
    So, upgrading to 10.11.1 did not fix my issue with a lagging wireless Apple keyboard. Upon first wake from sleep the keyboard exhibited the same symptoms.

    I've been searching this and other forums for insights since my problem started. I found an interesting thread on these forums that may have helped. The poster was having troubles with a Magic Mouse stuttering and losing connection. He finally solved his issue by moving (not copying) the plist files for Bluetooth onto his desktop and restarting his Mac. The plists were recreated upon restart by OS X and his problem was solved. Seems the Bluetooth connections profile had been corrupted and the fresh ones created by OS X restored the use of his mouse. I gave it a try and so far my keyboard has been working normally when coming out of sleep. My Apple keyboard, mouse and trackpad were automatically reconnected at startup, but other Bluetooth devices have to be re-paired.

    If you want to try it for yourself here are the steps the other poster outlined:

    "Move the following files to the Desktop and restart:

    • /Library/Preferences/com.apple.Bluetooth.plist*
    • ~/Library/Preferences/com.apple.Bluetooth.plist*
    • ~/Library/Preferences/ByHost/com.apple.Bluetooth.*
    It’s important to move (not copy) the files. This forces OS X to re-create the files on reboot. (I could have just deleted the files but I wanted to keep them around as backups in case something went wrong.) Since doing this, my Bluetooth devices have been happily connecting and disconnecting appropriately and I have no more stuck devices in my Preferences"

    Thanks to Matthew Bass for the above suggestion. I have placed my MacBook Pro into sleep mode several times and the keyboard continues to work as it should. Previously the keyboard lag would always be present when I woke the computer from an overnight sleep. This morning my keyboard was working normally. I am hopeful that the issue has been resolved, but will report back to let you all know how it goes over the next couple of days. I was just about to take the plunge and do a clean install of El Capitan (which probably would have solved the issue also) but hopefully won't need to go through the hassle now!
     
  6. eneisch macrumors 6502a

    Joined:
    Jul 11, 2008
    #6
    Unfortunately the issue started again after a couple of days. Only seems to happen when MacBook wakes from "deep sleep". Was going to do a clean install, but was advised by someone on Apple discussion boards that it would not solve the problem. Guess I will have to wait for Apple to come up with a fix in a future update.
     
  7. easonksh macrumors newbie

    Joined:
    May 9, 2011
    #7
    This is so annoying that I have to restart my macbook pro retina every time it comes back from sleep.
    @eneisch Have you tried to reinstall 10.11.1?
     
  8. eneisch macrumors 6502a

    Joined:
    Jul 11, 2008
    #8
    No I have not done a clean install of 10.11.1 based on advice in the Apple discussions forum in which someone else with the same issue did a reinstall of the OS and it did not fix the issue. To temporarily relieve the issue you can go to the energy settings pane and check "prevent this computer from sleeping when screen turns off". I have also read that instead of restarting your MacBook, turning the keyboard off and back on will also temporarily relieve the issue.

    There is a big thread in the Apple developers forum about this issue. The consensus there is that this is a bug in El Capitan that needs to addressed by Apple.
     
  9. eneisch macrumors 6502a

    Joined:
    Jul 11, 2008
  10. ctznalien macrumors newbie

    Joined:
    Oct 7, 2013
    #10
    I have the same issue with my late 2013 27" iMac after updating to 10.11. About a third of the time when waking from sleep, neither keyboard or mouse (both wired) are responsive, and I have to do a hard reset.

    Any developments on this besides just not letting it go to sleep properly?
     
  11. lsh macrumors 6502

    Joined:
    Feb 6, 2012
    Location:
    Cincinnati, OH
    #11
    I also have this problem. I changed my sleep options to uncheck sleep for hard drive and that seems to have improved the incidences of this problem.

    But it still happens. One thing I noticed, it SEEMS like it happens when I wake in a different location from where I went to sleep. I'm not sure if it's having unplugged for the commute or difference in wifi network or ???

    It is extremely annoying. I wish I could pinpoint when it started.
    I have latest OS X and a mid 2012 MBPR 15. I did replace the HD with a Transcend 1TB drive sometime ago.
     

Share This Page