Sleepimage deleting problem and missing place..

Discussion in 'macOS' started by Rethua, Dec 4, 2011.

  1. Rethua macrumors newbie

    Joined:
    May 24, 2011
    #1
    Hey there!

    I have a early Macbook pro 13.3" I have upgraded it with an optibay and have an Corsair 120gb ssd on it. 8 gb ram on it and running Lion 10.7.2.

    Couple hours ago i just realised that i didnt have any space left on my boot disk and i have researched some, checked my ssd with disk inventory and find out that my private/var/tmp folder was full. So i have cleaned it. I have around 43gb free space then.

    Then i have realised that i have a file which is 8gb and it was sleepimage file on private/var/vm/

    So i have tried to delete it just by moving it to trash. And empty the trash. Then the trash was empty, but the file just came back instantly.. My problem is then i have just 35gb left on my ssd. And i tried to delete manually 1 more time. Bang; i have 27gb left and sleepimage is still there...

    I have tried to delete it with "sudo rm -rf /var/vm/sleepimage" command. It works yeah, but i still have 16 gb missing on my SSD...
    -I took my hibernate stuff to 0
    -I have checked my disk with Omnidisk sweeper and Disk inventory x, i cant really see any file like sleepimage anymore, just 16 gb missing.
    -I have tried to repair the disk on diskutility and with diskwarrior, not working..

    This is just how it looks like and all i have on my ssd disk.
    http://imageshack.us/photo/my-images/221/screenshot20111205at428.png/

    Still missing someplace on my ssd and i have tried quite long time to fix it, nope i can't, need help!
     
  2. Mal macrumors 603

    Mal

    Joined:
    Jan 6, 2002
    Location:
    Orlando
    #2
    First, restart your computer.

    Second, the sleepimage is going to come back every time you put the computer to sleep, unless you disable safe sleep (google for instructions). Thus, deleting it is really not going to help you.

    jW
     
  3. Rethua thread starter macrumors newbie

    Joined:
    May 24, 2011
    #3
    I guess you didnt really understand what my problem is.

    I dont mind if sleepimage left or not. Im talking about the bug that took 16 gigs, when i was trying to delete it. And that 16 gg missing in my SSD even the sleepimage is left... Dont read just first 3 sentences... For sure i have restarted it couple times. I'm not that newbie lol.
     
  4. Mal macrumors 603

    Mal

    Joined:
    Jan 6, 2002
    Location:
    Orlando
    #4
    Oh, I understood. The suggestion to restart was the part meant to help with that, the rest was just clarification in case. Since you didn't say you'd restarted, I had to assume that you had not. Don't expect us to simply know all of the steps you've taken unless you write them out completely.

    Beyond that, I'd say either you're missing something with OmniDiskSweeper, or you need to rebuild the directory for your drive. You say you've run DiskWarrior, did it give you an error, or simply pass without issues?

    jW
     
  5. Rethua thread starter macrumors newbie

    Joined:
    May 24, 2011
    #5
    Thanks :)

    Well not any error when i checked and tried to fix it with diskwarrior. I'm pretty sure that i'm not missing anything on OmniDiskSweeper. Checked with disk inventory x also, same.

    By the way, i got 8 gb back just like that. Without doing anything, it came back. Now its just 8gb left which is missing. Sleepimage is still left on the disk also.. Maybe it fixes itself just like that :)
     

Share This Page