Slight video glitches with 2015 15" rMBP, should I be concerned?

Discussion in 'MacBook Pro' started by generationfourth, May 25, 2017.

  1. generationfourth macrumors newbie

    generationfourth

    Joined:
    Mar 7, 2017
    #1
    Relevant history: I've previously owned a 2011 15" MacBook Pro which died this year due to faulty graphics card/logic board. After that I purchased a 2016 15" tbMBP which had the serious video glitch issue amongst many other problems. I returned it.

    Since then I've picked up an apple cert refurb 15" rMBP. It's been working quit well aside from some very minor screen glitches, especially when connecting/disconnecting to my dell 4k monitor. It's not as bad as the 2016 tbMBP glitches. But reminiscent of the minor pixelation and glitches I had with the 2011 throughout its life until it got progressively worse and died a month after the service program was stopped.

    Is this normal, or should I be concerned?
     
  2. MRxROBOT macrumors 6502

    MRxROBOT

    Joined:
    Apr 14, 2016
    Location:
    1011100110
    #2
    First things first, is your certified refurbished rMBP equipped with the AMD M370X?

    If so, then these glitches are normal assuming you were running the Intel Iris Pro when when connecting to your external monitor. The thing is, the 15" rMBP will ALWAYS switch to the dGPU when an external monitor is connected. The switch that is occurring is the "glitch" you're seeing and when you disconnect it will switch back to the Iris Pro and you would see it again.
     

Share This Page