Slot Drive Manual Eject?

Discussion in 'MacBook Pro' started by TheBusDriver, Apr 3, 2007.

  1. TheBusDriver macrumors 6502

    Dec 24, 2005
    Is there any way to manually eject a disc from a slot drive, on the macbook.
  2. tyr2 macrumors 6502a


    May 6, 2006
    Leeds, UK
    Don't think so. If it's stuck in try rebooting whilst holding the trackpad button whilst it boots, it should eject it.
  3. deadpixels macrumors 6502a

    Oct 30, 2006
    i don't own a macbook but there's no eject key? on my ibook g4 it's F12.
  4. TheBusDriver thread starter macrumors 6502

    Dec 24, 2005
    what if one can't restart, Installing vista it says eject the first disc and put in the second, well the first one won't eject...
  5. kolax macrumors G3

    Mar 20, 2007
    I got the same problem when installing Media Centre on my Mac - CD 2 of XP is the Media Centre capabilities and had to click cancel and it left out all the media stuff (which suited me better anyway!).

    I tried everything to get the CD out and none worked
  6. gillilandboy macrumors 6502

    Apr 3, 2007
    St. Louis MO
    I have had this same problem on my mac. Take a paper clip and make it long ways and stick it in the cd slot and the Cd should pop out.
  7. trudd macrumors regular


    May 27, 2004
    What kind of Mac was it? I'm not so sure the MBP's optical drive has that magic button.
  8. kolax macrumors G3

    Mar 20, 2007
    As far as I can see, MBP doesn't have any visible eject button round the drive.

    And I'd feel a bit weary about poking a paper clip into my optical drive.
  9. konfuzion macrumors member

    Jul 7, 2006
    Bay Area
    Thats exactly why Boot Camp specifically says that install discs need to be only 1 CD. It's not capable of letting you swap discs mid install.

    The way to solve the problem is by holding down the mouse button while restarting.

Share This Page