SLOW 3G with iPhone 4

Discussion in 'iPhone Tips, Help and Troubleshooting' started by mattster16, Jun 29, 2010.

  1. mattster16 macrumors 6502a

    Joined:
    Apr 18, 2004
    #1
    Are other people getting such slow download speeds but FAST upload speeds over 3G with their iPhone 4? This is driving me nuts! I can barely stream Pandora over this connection at times. With my 3GS I got as much as 4,000! kbps down and usually averaged around 2,000. What is going on with this thing? Test was performed with the phone on a table, not the 'death grip' issue.

    PS I'm in downtown Minneapolis in case anyone else who reads this is here too and can confirm my findings.
     

    Attached Files:

  2. RetardedGoat macrumors newbie

    Joined:
    Jun 29, 2010
    #2
    Same problem

    I'm having the exact same problem. I took it in to the Simply Mac store and laid my iPhone 4 right next to my girlfriend's iPhone 3Gs. Her phone smoked mine. Sometimes mine would even timeout. He said I should just wait for an update. But I'd love confirmation that this is a problem recognized by Apple and slated to be fixed. It is sporadic. Sometimes it works. Sometimes it doesn't. But it's not something I can live with. It seems like it didn't become a problem until after I synced it for the first time. SHRUG. But I'm not sure.
     
  3. mcmlxix macrumors 6502a

    Joined:
    Mar 10, 2009
    #3
    I work downtown Mpls and live nearby as well.

    Using Speed Test I've noticed that uploads are often faster than downloads. Also there are periods when 3G data drops out for up to 10 minutes at a time. I haven't noticed any pattern in times.

    PS...I had assumed that the reason was due to AT&T in this area. Would it be hardware/firmware instead?
     
  4. mattster16 thread starter macrumors 6502a

    Joined:
    Apr 18, 2004
    #4
    I'm not sure what the problem is but I never had it until I got my iphone 4. There is literally an at&t tower outside my apartment window across the street and I'm still having the issue so I don't believe it has anything to do with reception - I always have 5 bars. It's been happening for days so I don't think its at&t.

    I can no longer stream pandora over 3g on my walk to work either, always cuts out. Never once happened before.

    Hopefully if it's firmware Apple can fix it, SOON.
     
  5. Bluestudios macrumors newbie

    Joined:
    Jun 30, 2010
    #5
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_0 like Mac OS X; en-us) AppleWebKit/532.9 (KHTML, like Gecko) Mobile/8A293)

    I am in mpls (northeast to be exact) been having the same issue since yesterday around 2pm. Word on the street is AT&T has multiple towers with 3G data issues across the country. My wife still has her 3GS and her data speed tests are terrible here as well. I work in Eagan and the problem is worse for me there. I spot tested all the way home tonight and hit great transfer rates on Hiawatha between 46th and 35th. So it's a moving target to say the least. Makes for a long workday though.
     
  6. tivoboy macrumors 68030

    Joined:
    May 15, 2005
    #6
    tower and STRENGTH

    depending on where I am I get some SICK speeds.

    3100kps down and 1260 max up. That is some nice speeds
     
  7. mattster16 thread starter macrumors 6502a

    Joined:
    Apr 18, 2004
    #7
    I'm beginning to think this has to be at&t in the area and not the phone. It was working well this morning but 3G is crawling again now. I've only used my phone downtown near the stadium/warehouse district...so a pretty small geographic area. It is odd that this has been happening for about a week now.

    I don't feel sooo bad anymore about the iphone 4 now that I know other people are having the same problems.

    We'll see....
     
  8. splizaat macrumors member

    Joined:
    Jun 30, 2010
    Location:
    Oregon
    #8
    my 3gs seemed a bit faster than my iphone4 on internet browsing... :(
     
  9. Dr Kevorkian94 macrumors 68020

    Joined:
    Jun 9, 2009
    Location:
    SI, NY
    #9
    its the phone i have a problem where the loading bar in safari will not move at all and even time out, sometimes it will not load for like a minute or to the load super fast. this sometimes happens on wifi too, so im confidant that its the phone. when i do the speed test it is VERY different each time.
     
  10. secrethero303 macrumors newbie

    Joined:
    Jun 22, 2010
    #10
    I work in downtown Minneapolis and have been having the same issues. I get anywhere from 0-200/kbps download and up to 300/kbps upload. At home (Blaine), I get around 3000/kbps down and 1800/kbps up.

    It seems like it is a network issues, since I've tried all of the troubleshooting steps (including having ATT replace the microSIM). I'm trying the genius bar tonight, but I don't think they will offer much help. I'll let everyone know if they tell me anything new.
     
  11. djinn macrumors 68000

    djinn

    Joined:
    Oct 4, 2003
    #11
    My Iphone 4 is horrible on 3G. I have full signal and at times, it will just stop working, still showing full bars. I usually have to reboot or just wait for it to catch up. And yes, I have done a restore, no luck.

    I hope a fix is on the way.
     
  12. Farplaner macrumors 6502

    Joined:
    Aug 4, 2008
    #12
    I'm having problems with my 3G data as well! Even with 5 bars 3G data access is just sporadic. The strange thing is that if I turn off 3G (and let it go to edge), everything appears to work well. Turn on 3G, very slow speed or just none altogether. Rebooting the phone appears to fix the problem.

    Very frustrating.
     
  13. djinn macrumors 68000

    djinn

    Joined:
    Oct 4, 2003
    #13
    I'm having EVO Flashbacks. It's a moody 3G network tonight.
     
  14. txmike macrumors newbie

    Joined:
    Jul 14, 2008
    #15
    AT&T screwed up Minneapolis.

    I heard rumors of this a couple of days ago..

    But apparently, AT&T was doing some work near Minneapolis on their 3G network and screwed something up. That's why so many are having issues up there right now.

    I live in Texas, but I was up in downtown MSP from Tuesday through Friday on business and my 3g service was truly horrific during the daytime. At night, the service got much better as downtown was evacuated by the commuters. I spent all my time near Nicolette Mall. Even at the Airport yesterday afternoon, service was bad. But when I got back to Austin, all the 3G issues went away and my iPhone4 is working fine now.
     
  15. Farplaner macrumors 6502

    Joined:
    Aug 4, 2008
    #16
    One thing I did find out the past couple days is that, for my 3G issues, it was actually because of airplane mode! Apparently, after switching Airplane mode on and off, my 3G data just dies.

    I thought there was something wrong with my 3G and switching Airplane mode on and off (as a reset) to troubleshoot, and this was the reason why I thought there was an issue with my 3G access.

    Now if I don't ever touch airplane mode, my 3G access is fine, and I do a hard reset (power off and on) to troubleshoot from now on.
     

Share This Page