Slow airport initial connection

Discussion in 'Mac Basics and Help' started by Asherlc, Oct 2, 2008.

  1. Asherlc macrumors newbie

    Joined:
    Oct 2, 2008
    #1
    Hi,
    On my macbook, it takes about 10 seconds for my airport to connect to a wireless network. This happens both with a WRT541G and an Airport Extreme router, so I am sure the problem is with my laptop. Sometimes, it will not show the network in the list of networks, but I will have to manually click on it to connect, even though it is in my preferred networks list.

    Is this a known problem? Any solutions?
    Thanks,
    Ash
     
  2. soberbrain macrumors 65816

    soberbrain

    Joined:
    May 9, 2008
    #2
    Are there other WiFi signals in your area? Perhaps they are interfering with your routers?

    Try changing your router's wireless channels.
     
  3. millerrh macrumors 6502

    Joined:
    Sep 14, 2005
    #3
    I have the same problem with my MBP. But mine takes a minute or MORE sometimes before it connects after I wake it up from sleep. This isn't a problem with my router because I see this behavior no matter where I am.
     
  4. aminewyork macrumors newbie

    Joined:
    Oct 2, 2008
    #4
  5. kolax macrumors G3

    kolax

    Joined:
    Mar 20, 2007
    #5
    Changing the wireless channel 9 times out of 10 is the solution. As already said, if other wireless networks in your area are on the same channel, it will cause interference and result in poor network performance.

    Although I doubt that both routers you listed would be running on the same channel. Possible though.

    To check, press the Option key (a.k.a 'alt') and click on the AirPort icon. It'll list the wireless channel of the router you are connected to. Compare and see if they are both on the same channel.
     
  6. aminewyork macrumors newbie

    Joined:
    Oct 2, 2008
    #6
    That is a great suggestion but I set up both routers on different channels. Presently the Time Capsule is on channel 36 and the Airport Extreme is on channel 11
     
  7. aminewyork macrumors newbie

    Joined:
    Oct 2, 2008
    #7
    I fixed my problem by following the steps listed in the last post here

    http://discussions.apple.com/thread.jspa?threadID=1736912&tstart=1

    OK, I did some fiddling with the settings and I managed to get it down to 6 seconds. The problem apparently is the order of your network interfaces in your network settings.

    * Open system preferences / network (I am assuming you are using Leopard).
    * In the window on the left delete those interfaces you do not use (bluetooth for example - do not worry, you can alway add them later on).
    * Select the symbol on the right of the minus sign and choose "set service order". Make sure that airport is first. Then press "apply".
     

Share This Page