Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

slow and hanging internet on new wifi

AceGuy78

macrumors member
Original poster
Dec 25, 2011
93
1
USA
I just added a second router in the house...got it working by plugging in the new router into the back of the original router.. but now i've seen slow speeds and hanging on my iPhone and Macbook... I'm wondering if its a bandwidth problem since i have one router plugged into another or if my apple products don't like the new set up
Any Ideas?

Ace
 

Tander

macrumors 6502a
Oct 21, 2011
676
1
Johannesburg, South Africa
Since you've plugged in the new router - did you turn off DHCP on the new router?

Chances are you have two routers trying to give out DHCP addresses - and not configured as an access point-only-mode.

If that's the case - slow, and hanging internet speeds will happen.
 
Comment

AceGuy78

macrumors member
Original poster
Dec 25, 2011
93
1
USA
Since you've plugged in the new router - did you turn off DHCP on the new router?

Chances are you have two routers trying to give out DHCP addresses - and not configured as an access point-only-mode.

If that's the case - slow, and hanging internet speeds will happen.

No sir I did not... I will do it right now and get back to you
 
Comment

AceGuy78

macrumors member
Original poster
Dec 25, 2011
93
1
USA
Since you've plugged in the new router - did you turn off DHCP on the new router?

Chances are you have two routers trying to give out DHCP addresses - and not configured as an access point-only-mode.

If that's the case - slow, and hanging internet speeds will happen.

I did what you said but it's still slow and hanging and now my iphone won't connect to the wifi at all!... any other tips?
 
Comment

Tander

macrumors 6502a
Oct 21, 2011
676
1
Johannesburg, South Africa
Okay go through these steps.

1. Make sure DHCP is off on new router.
2. Make sure DHCP is oON old router.
3. Make sure wireless is turned off on old router
4. Setup wireless on new router.

Disconnect all devices and reconnect to 'new router wireless'

If your aim is to have extended wireless connectivity (I assume this is the case, since you've added this second router)

Then ignore steps 3 and 4 above.

Make sure:

1. Wireless is turned on with both routers.
2. Second router is in AP-Only mode.
 
Comment

weezer4272

macrumors newbie
Jan 18, 2006
15
0
Also make sure they are on different channels. Many cheap home routers will default to the same channel and then you get interference.

If you're running in the 2.4 GHz band, pick two non overlapping channels from 1, 6, and 11.
 
Comment

AceGuy78

macrumors member
Original poster
Dec 25, 2011
93
1
USA
Okay go through these steps.

1. Make sure DHCP is off on new router.
2. Make sure DHCP is oON old router.
3. Make sure wireless is turned off on old router
4. Setup wireless on new router.

Disconnect all devices and reconnect to 'new router wireless'

If your aim is to have extended wireless connectivity (I assume this is the case, since you've added this second router)

Then ignore steps 3 and 4 above.

Make sure:

1. Wireless is turned on with both routers.
2. Second router is in AP-Only mode.

AP-Only mode did the trick, I'm now getting equally fast speeds on both routers! Thanks for your help!
Ace
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.