Slow charging time. Charging with 2.3 watts

Discussion in 'MacBook Air' started by Bigdrago, Feb 28, 2015.

  1. Bigdrago macrumors newbie

    Joined:
    Jan 16, 2015
    #1
    Hi.
    I have cleaned everything after someone spilled coca-cola on my macbook air 13" mid 2013.
    After cleaning all components works, even did a full reinstall of yosemite.

    But the charging time is extremely long. From 2% to 100% it took over 20 hours. According to batteryhealth it is charging with 2.3 watts.
    Yes I have tried other chargers with the same result.

    I changed the I/O board cable and suddently it charged with full power. But the next day when inserting the charger it is charging slow again with 2.3 watts.

    So... are there any fuses I can change?
    Or is it the battery that needs to be changed? Battery age 1.7 years, cycles 93, original max 7150mAh, health 95%.
    But the health got to 99% when the charger was charging full. Now it is back to 95% when charging with 2.3 watts.

    Taking it to a repair shop wont do any good...because one of the LSI indicators on the logic board is red. Yes I have reset SMC.
     
  2. motrek macrumors 68020

    Joined:
    Sep 14, 2012
    #2
    Dunno but please realize that the laptop doesn't charge at a constant rate. It will charge quickly until 80% and then slowly and then after ~95% it charges very, very slowly.

    I have seen OS X predict 40 minutes to charge from 98% to full.

    This is presumably so the battery doesn't get overcharged and damaged.

    So be aware of this when you are measuring charge rates.
     
  3. Bigdrago thread starter macrumors newbie

    Joined:
    Jan 16, 2015
    #3
    Yeah... but from 2% to 80% should not be 20 hours of charging :) Maybe the batteri itself think it is 95% and therefore charging slow...
     
  4. Bigdrago thread starter macrumors newbie

    Joined:
    Jan 16, 2015
    #4
    Interesting.. I disconnected the battery before going to bed, then it had about 70%.
    This morning I connected the battery and inserted the charger. I noticed that the charger was giving 44W with a monitor, the app "battery health" also showed full charging speed. After a few minutes it decreased to 2.4 watts again. :/
     
  5. illusionx macrumors 6502

    Joined:
    Jul 4, 2014
    Location:
    Brossard, QC
    #5
    I am guessing that the cola did some damages to the motherboard or the battery itself.
     
  6. Bigdrago thread starter macrumors newbie

    Joined:
    Jan 16, 2015
    #6
    Well... the mac itself suck all the power if wants... but t seems like the battery doesn't much juice...
     
  7. illusionx macrumors 6502

    Joined:
    Jul 4, 2014
    Location:
    Brossard, QC
  8. Bigdrago thread starter macrumors newbie

    Joined:
    Jan 16, 2015
    #8
    The same. Outlet showing about 4 watts.
     
  9. Bigdrago thread starter macrumors newbie

    Joined:
    Jan 16, 2015
    #9
    Bought a new battery and I/O board... still slow charging.
    Guess it must be a charging circuit on the logic board causing the problem...
     

Share This Page