Slow graphics performance in SL. Expose and Spaces

Discussion in 'macOS' started by TennisandMusic, Aug 29, 2009.

  1. TennisandMusic

    Joined:
    Aug 26, 2008
    #1
    I am seeing very slow performance when using spaces and expose in 10.6. I am on a mac mini with the 9400m graphics chip. It worked perfectly in Leopard, and now it runs at what appears to be 1fps. Sometimes it doesn't even seem to animate, it just jerks into place, from starting point to the end.

    I realize one solution could be "do a fresh install" but that seems like quite the pain at the moment, and is extremely undesirable. The upgrade worked perfectly on my macbook pro with similar specs.

    Is there anything I can reset or reinstall that might refresh the graphics performance?
     
  2. XheartcoreboyX macrumors 6502a

    XheartcoreboyX

    Joined:
    Jul 3, 2007
    #2
    Bump...i have the same problem, it's even with coversutra's search bar and Quicksilver..

    Every animation is so jerky and it was a fresh install.
     
  3. Mugwumper macrumors regular

    Joined:
    Jan 19, 2008
    Location:
    Palmdale, CA
    #3
    Very strange . . .

    I wonder if it has to do with being a Mini or the 9400?

    I see none of what you describe on my iMac from last year with the 8800GS
    graphics. I have 512MB RAM for the graphics - how much does the 9400
    have? And how much system RAM do you have?

    In fact, I finally have the Spaces and MS Office incompatibility problem
    resolved in SL.

    By the by, I'm also running HyperSpaces - I wonder if that helps or hurts
    your situation?

    And I elected not to do the clean install, either - too much time . . .

    Sorry yours is so choppy - I'm very happy . . .
     
  4. TennisandMusic thread starter Guest

    TennisandMusic

    Joined:
    Aug 26, 2008
    #4
    Has there been any info in regards to what causes this? Again my nearly identical macbook pro (both use the 9400m) runs very smoothly, no complaints. Both were the straight ahead upgrades. One machine is smooth as silk, the other runs at practically 1fps on those two features.
     
  5. Macula macrumors 6502

    Macula

    Joined:
    Oct 23, 2006
    Location:
    All over the place
    #5
    I can confirm that this issue is not specific to graphics cards or drivers. Installed on a Macbook and a Macbook Air, both with X3100 graphics, Snow Leopard gives me ridiculously jerky animations in the former and is smooth as silk in the latter.

    I am really bothered by this since I use 9 spaces, with lots of windows open, and really need them all.

    The only pattern I've noticed is that the issue is aggravated by the presence of an external monitor. Other than this, no explanation whatsoever.
     

Share This Page