Slow Interent speed(18.500 average)

Discussion in 'Mac Basics and Help' started by charlie256, Feb 5, 2009.

  1. charlie256 macrumors newbie

    Joined:
    Feb 5, 2009
    #1
    Hello All,

    So Im not exactly a new user... but Ive only used my MAC for art apps.

    I have a PowerMac G5 running tiger and am having painfully slow internet connection speed.

    There are 2 comps hooked to the router from the modem(my MAC and a PC), then another Router between the MAC and an XBOX 360.

    The other comp has consistently fast internet speed.

    I pinged www.google.com and got the average above, no packet loss.


    OK, I have:

    -reset modem and both routers
    -contacted my ISP all ok there
    -bypassed the both routers and still slow(this leading me to think its a software-settings problem on my end)
    -reinstalled OS


    still slow. besides preforming a seance I am clueless, which isnt saying much. anyone have any suggestions?
     
  2. charlie256 thread starter macrumors newbie

    Joined:
    Feb 5, 2009
    #2
    ...hehe, so forget it. I figured out the problem. And also mislabeled the thread.

    a clearer explanation of the problem would have been:

    slow page loading... my browser would hiccup about half way through loading causing painfully slow browsing.

    My connection wasn't slow, my network settings were off. Not to mention daisy chaining 2 routers was a problem.

    I replaced router B with a switch. I then scoured the net to find a helpful tip from one "Hawiian_starman":

    "Go to the System Preferences>Network panel
    - Location - set up a personal location by clicking on the drop down menu and selecting "add a location". Use a name familiar to you. Once established, select "apply".

    * Next, click on the "Show" drop down menu and select Network Port Configurations. Only Ethernet ought to be checked. Move it to the top of the list (you can drag it). Select "apply".
    * Back to the "Show" menu, select "Ethernet". Click on the TCP panel. There enter 4.2.2.2 in the DNS servers box and select "apply".


    Creating a personal location seems to speed things up. Otherwise, the "automatic" function has a tendency to "search" for available locations.

    In the Finder, go to your Utilities folder and select "Terminal". Once the screen is open enter lookupd -flushcache and press return. This clears out the DNS cache. Once done, quit Terminal.

    Restart the computer, then try Safari. Post back and let me know how you make out. "


    ..worked like a charm.
     

Share This Page