slow internet / browser after MacOS X 10.6.3

Discussion in 'macOS' started by lyteck, Mar 30, 2010.

  1. lyteck macrumors newbie

    Joined:
    Apr 2, 2009
    Location:
    New York, NY
    #1
    I experience slow/partial web browsing after upgrading from 10.6.2 to 10.6.3 last night 3/29

    Some web sites without much graphics will work fine and fast (e.g., google.com, yahoo mail, wikipedia, outlook web access from work), but others will start loading but never complete loading (e.g., cnn.com, moviefone.com, ebay.com are loading forever)

    This happens on both Safari 4.0.5 and latest FireFox 3.6.2.
    This happens whether wired or wireless
    I have shutdown several times, recycled both cable modem and wireless router, emptied Safari Cache, not to avail.

    Any similar experience? Please help.
     
  2. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #2
    Have you tried www.speedtest.net and maybe have comparative results from an earlier speed test?
     
  3. lyteck thread starter macrumors newbie

    Joined:
    Apr 2, 2009
    Location:
    New York, NY
    #3
    The internet connection doesn't seem to be the problem... as other computers are working fine.

    I just tested on speedtest.net and I get a decent down/up speed of 9.02 MB/s / 0.49 MB/s
     
  4. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #4
    Try clearing your cache to see if that helps. Also download a different browser like firefox to see if the results are better.
     
  5. ecapdeville macrumors member

    ecapdeville

    Joined:
    Nov 22, 2005
    Location:
    Mexico City
    #5
    I´m having similar problems but in my case, safari and Google chrome browsers unexpectely quit and the reason was that the browsers were having problems with the flash content... this beheavour happened with my Imac i5 27" and my MacbookPro unibody 13" after installing 10.6.3
     
  6. ai840 macrumors newbie

    Joined:
    Apr 28, 2010
    #6
    I experience the same problem, may be on different sites, but still.
    Very slow loading of pictures and other elements, especially if site is complicated, working on CMS, like Joomla or others.
    And the problem is complete the same on both Safari 4.0.5 and Firefox 3.6.3.
    It started after 10.6.3 Mac OS X Update.

    I solved this problem by moving from Safari 4.0.5 to new Opera 10.52 for Mac.
    On Opera 10.52 everything is working fast. I love Safari, but 10.6.3 Update was very disappointing.
     
  7. SurfSpirit macrumors member

    Joined:
    Mar 11, 2006
    #7
    10.6.3 is Slower!

    I also done benchmarks, my computer is noticeable slower with 10.6.3, on startup and shutdown, already done cleanup, something in the 10.6.3 code that Apple needs to fix, fast! I also tried Ubuntu 10.04 LTS on my computer, and heck, it's twice as fast as my Mac OS X, so much for Snow Leopard deep optimizations :(! Just wish Apple don't forget Mac OS X now that news are only iPhone/iPad relative!!!
     
  8. sauria macrumors regular

    Joined:
    Jul 2, 2001
    Location:
    Texas, USA
    #8
    Same Problem

    My Wireless N syncs to an Apple TV are now 40% slower than under 10.6.2.
     

Share This Page