Slow Internet connection w/VPN and PPPoE in Leopard

Discussion in 'macOS' started by StuBeck, Jun 29, 2008.

  1. StuBeck macrumors 6502

    Joined:
    May 6, 2008
    #1
    On campus I'm required to connect to the Internet via a PPPoE connection and VPN. I had a MBP running Tiger and Leopard, and now have a MB running Leopard, and both have been rather slow when connecting to the Internet. When I connect via Windows in boot camp, the Internet is rather fast. Using the BBC iPlayer I can easily watch a tv show, where if I try the same thing in OS X I get about 5-10 seconds of playing and then a 30 second wait. Clearly it is an issue with OS X handling the connection.

    I am wondering what can I do to make it faster? I have the PPPoE connecting sending PPPoE echo packets and using verbose logging. The VPN uses 128 bit encryption, uses verbose logging, and "send all traffic over VPN" is not clicked. I have disabled IPv6 for both connections and the Ethernet connection as well.

    Thank you for any help you can give.
     
  2. Amdahl macrumors 65816

    Joined:
    Jul 28, 2004
    #2
    That is an interesting problem.

    One big difference between Windows is that it sets the MTU on tunnel connections much lower than any other system. So, there is a chance you are running in to an MTU problem, probably because of a misconfig on the part of the PPPoE or VPN server or servers router.

    Once you are fully connected, you can try lowering your MTU in Terminal. Type 'sudo bash' and press enter. Enter your system password. Then ifconfig and press enter. Hopefully you can figure out which of the tun or ppp prefixed devices is the one for your VPN. Assume it is ppp1. Type ifconfig ppp1 mtu 1300 and press enter.

    See if your Internet works better after that.
     
  3. operator207 macrumors 6502

    Joined:
    Jul 24, 2007
    #3
    Try "netstat -r -n -f inet" look for "default" in column 1, then look in the "netif" column to find out what interface. That should be his default interface for all traffic, if he is piping all traffic through the VPN. It may be more convoluted than that if he is doing wireless, pppoe and then VPN, as the default may be the hardware interface, and not a virtual one.
    It has been a year since I did VPN, and used the route statement to route some traffic via the VPN and other through the interface itself.
     
  4. Amdahl macrumors 65816

    Joined:
    Jul 28, 2004
    #4
    If wireless is involved, the first thing to do is see if the problem goes away when plugged in instead. If it does, then are you running the latest updates? If so, probably give up, or try talking to the wireless administrator and check for firmware updates to the access points.
     
  5. StuBeck thread starter macrumors 6502

    Joined:
    May 6, 2008
    #5
    This is all wired, my campus isn't advanced enough to put up a AP in every dorm for wireless :lol:

    I set the MTU to 1300, but before that noticed the MTU for ethernet is 1500 (understandable), ppp0 (PPPoE) was 1450 and ppp1 (VPN) was 1396. I set it to 1300 like you said and will test it out to see how it is now. Thanks a bunch!
     
  6. Amdahl macrumors 65816

    Joined:
    Jul 28, 2004
    #6
    Those numbers sound fine; I'm going to be a little surprised if mtu 1300 fixes the problem. Are you running 10.5.3?
     
  7. StuBeck thread starter macrumors 6502

    Joined:
    May 6, 2008
    #7
    I'm running 10.5.4 now, but was running 10.5.3. It hasn't really helped, the internet is still stupid slow in OS X, and fine in Windows.
     
  8. Amdahl macrumors 65816

    Joined:
    Jul 28, 2004
    #8
    I'm stumped. See if anyone on campus can look at it.

    A remote possibility(but it does happen) is a mismatch between the Ethernet port speed and the switch you plug in to. You can go to Network Preferences, Built-in Ethernet, Advanced, Ethernet. Change Configure to Manually, and try changing the Duplex to various settings and see if the problem clears. You can try changing speed to 100 or 10 as well, and try each Duplex setting. Leave the MTU at 1500.
     
  9. operator207 macrumors 6502

    Joined:
    Jul 24, 2007
    #9
    Try 1460 for your MTU, see if that helps any. If that does not help, try 1496, are you behind a router at your location? Or are you literally plugged into a wall port that is plugged into a switch in your building?

    These MTU's are for your ethernet adapter, not the VPN adapter. I am wondering if this is something to do with your ethernet settings, and not the VPN itself. I am also wondering if this could be an auto negotiation setting for the ethernet adapter. I have seen some weird throughput when you have a mismatched ethernet speed. Though its usually a Cisco auto negotiation to a no name ethernet adapter's auto negotiation. Which is not something you will be able to fix unless you have control of both sides of the connection.
     

Share This Page