Slow Internet in Leopard

Discussion in 'macOS' started by The Flashing Fi, Jan 20, 2008.

  1. The Flashing Fi macrumors 6502a

    Joined:
    Sep 23, 2007
    #1
    Hey guys. I have extremely slow internet on my Mac where I live. It's perfectly fine in Vista on my MBP and is fine on Vista/XP on my desktop (it's not a Mac). I had the same problem on my old laptop in Linux (Ubuntu). I was wondering if there is anything I can do to help it out? I don't know my provider, as the internet is through my apartments. The internet isn't unusable, and once when I load the site, it's fine.

    It's really bad in Safari, but it's a bit better in Camino/Firefox.

    I'm sure it has something to do with Unix (and Unix-like) OS's and how they handle networking and my appartment's internet configuration.
     
  2. KingYaba macrumors 68040

    KingYaba

    Joined:
    Aug 7, 2005
    Location:
    Up the irons
  3. The Flashing Fi thread starter macrumors 6502a

    Joined:
    Sep 23, 2007
    #3
    1416 kbps Download
    722 kbps upload

    On my desktop in Windows XP, I get:

    1379 kbps Download
    706 kbps Upload.

    To be more specific, it seems that it takes a long time to initialize the connection with the website. After it's initialized, the website download is quick.
     
  4. prostuff1 macrumors 65816

    prostuff1

    Joined:
    Jul 29, 2005
    Location:
    Don't step into the kawoosh...
    #4
    do you have a router in between the connection??

    I found that unless i put in the DNS Server numbers my connection was crappy. If you have a router then log into it and find the DNS Server numbers (mine are located in the status section of my router settings). Anyway, find those number (usualy a primary and a secondary) and put those in the boxes in the network settings of System Preferences.

    Hope that helps fix the slowness
     
  5. ScoobyMcDoo macrumors 65816

    Joined:
    Nov 26, 2007
    Location:
    Austin, TX
    #5
    Your apartment networks is probably based on windows so your vista box is probably using the network's WINS server for name lookup. See what you are using for DNS. If the network you are using has an admin you can call, see if they can do something to fix the DNS server. Otherwise, I think there are some public DNS servers out there that you can use.
     
  6. The Flashing Fi thread starter macrumors 6502a

    Joined:
    Sep 23, 2007
    #6
    I tried a new DNS address (from Open DNS), and it's still a no-go. Things are still slow.
     
  7. ScoobyMcDoo macrumors 65816

    Joined:
    Nov 26, 2007
    Location:
    Austin, TX
    #7
    Well, the only thing I can think of to suggest is to fire up wireshark to try to identify the problem.
     
  8. wesley7373 macrumors newbie

    Joined:
    Aug 19, 2008
    #8
    I am sorry for bring this old thread back to life, but i am having the exact same problem as this user and i am just wondering if any ever solved the problem?
     
  9. Amdahl macrumors 65816

    Joined:
    Jul 28, 2004
    #9
    It seems this problem is usually DNS server related, although it may also be cured(much less often) by turning off IPv6 on whatever connection you use to access Internet.

    Try changing the DNS servers on your connection to 208.67.222.222 and 208.67.220.220, which are OpenDNS servers.

    The problem is either in OS X, your router, or your current (ISP?) DNS servers. You might check that your router (if any) has the latest firmware. Also make sure you are up to date on your Software Updates for OS X.
     
  10. wesley7373 macrumors newbie

    Joined:
    Aug 19, 2008
    #10
    Yes it is the the DNS that is the problem but i have my router using the open DNS connection and i have set my COnfigurations on my mac to manual and then changed its DNS to OPen DNS but its still slow, what am i missing here.
     
  11. Amdahl macrumors 65816

    Joined:
    Jul 28, 2004
    #11
    You can try turning off IPv6, and try plugging directly in to your Internet without the router. For IPv6, while in Network Preferences for Ethernet, click Advanced and set Configure IPv6 to Off.
     
  12. wesley7373 macrumors newbie

    Joined:
    Aug 19, 2008
    #12
    I have that turned off and we are still running slow. Now if i type the ip address we are good to go though.
     
  13. Amdahl macrumors 65816

    Joined:
    Jul 28, 2004
    #13
    I would try taking your router out and plugging in directly. If it still doesn't work right, your ISP might be intercepting all DNS requests, and encountering whatever incompatibility exists between OS X and certain servers.

    Others have reported the problem goes away be downloading and installing a nightly build of Webkit at Webkit.org.
     
  14. wesley7373 macrumors newbie

    Joined:
    Aug 19, 2008
    #14
    Yeah pluggin right into the wall does not help even with running OpenDns, i will give the webkit a try and then try calling the ISP.
     
  15. geekygrammy macrumors newbie

    Joined:
    Jun 7, 2008
    #15
    Worked for me

    Thanks for posting this info.
    I added the two OpenDNS servers and heyPresto all was well.
    I spent about a half hour with Apple tech support and got nowhere. She had me zap the PRAM and unplug everything and delete the cache.
    Then she told me my mac was slower on the net than my PC because Apple is more secure and doesn't get viruses because it checks the websites first.

    I spent about 2 minutes on this forum and the problem was solved. Makes me wonder whether I should invest $119. for extended applecare.
    I guess I will just for the hardware.
     

Share This Page