Slow Internet Speeds Compared to Windows 10 Bootcamp

Discussion in 'macOS Sierra (10.12)' started by Broken Hearted, Sep 25, 2016.

  1. Broken Hearted macrumors newbie

    Joined:
    Jul 17, 2011
    #1
    So about 3 weeks ago I had AT&T Uverse Gigapower installed. I was supposed to get 1 Gig down and 1 Gig up. They came and installed it, and speedtest revealed I was only getting about 580 megs down and roughly the same up. Which is below their standards of 600 megs down. I told the guy it was close enough and I would deal with it.

    Over the past two weeks, random tests indicate its dropped down to about 480 down. So I called and had a repair tech come out yesterday. He couldn't find anything wrong with the line. He wanted to blame the computer. The computer is "3 months old". Really its a late 2015 iMac that I purchased new 3 months ago. It has 32 gigs of Ram, 3.2ghz processor. He told me maybe my ethernet card was bad. I showed him netstat which showed I was connected to a gigabit connection, that it was indeed recognizing. He left agreeing sending it to his engineer team to see what they can do.

    After he left, I went and bought Windows 10, and installed it on bootcamp. Everyone kept asking me do I have another computer to test with, and that was the cheapest option to put that argument to rest as technically it would be another computer. To my amazement, after getting everything installed, I ran the test and Windows 10 was pulling 820 megs down and roughly the same up.

    So my questions are what settings in OS X are preventing me from seeing the same speeds that Im getting in Windows 10? Because that is literally the only thing that is changing. I had El Capitan, and it was the same issue. I upgraded to Sierra, hoping my speeds would improve. Are there any tweaks I can use to get more speed out of OS X? Ive used Namebench to get the best DNS servers and inputted those. Anything else?
     
  2. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #2
    Try navigating to

    Macintosh HD/ Library / Preferences /

    And move 'SystemConfiguration' to trash. Reboot and the try the internet again.

    This will reset all your network settings.

    You can restore the file from trash if you wish
     
  3. Broken Hearted thread starter macrumors newbie

    Joined:
    Jul 17, 2011
    #3
    I tried to move the entire folder, and it said it can't move it to the trash because it can't be modified or deleted because it is required by macOS.
     
  4. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
  5. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #5
    Might be System Integrity Protection blocking you from deleting that folder. Try:

    1) Turn off your Mac
    2) As soon as you turn it back on, hold CMD+R on startup. This will boot into OS X Utilities.
    3) Click 'Utilities' at the top menu bar and select 'Terminal'
    4) Type csrutil disable and press Enter
    5) Click Apple menu>Restart

    Should be able to delete the folder now.

    To troubleshoot the issue, you can also create a new user account, and see if the speed deficit persists through there. Also you can try reset PRAM/SMC.
     

Share This Page