Slow Internet speeds

Discussion in 'iMac' started by suparobg, Jun 11, 2013.

  1. suparobg macrumors newbie

    Joined:
    Mar 3, 2013
    #1
    Browsing the internet today and the loading of pages are painfully slow. I do have cable internet through Videotron (in Quebec, Canada) My imac is the 21.5 inch model from early 2013. Is there anything I can do on the computer side to help speed things up.
     
  2. Bear macrumors G3

    Joined:
    Jul 23, 2002
    Location:
    Sol III - Terra
    #2
    It depends on why it is slow. It might not be anything to do with your computer at all.

    Have you tried various websites to see how responsive they are?
     
  3. Racineur macrumors regular

    Racineur

    Joined:
    Jun 11, 2013
    Location:
    Montréal, Québec
    #3
    I'm in Québec too with Videotron and so slooow today

    :(Hi. Gee, I posted on the App forum about the same thing. Woke up this morning and the loading of pages is painfully slow to me too. Since I did the Apple Security Update 20013-02 (Snow Leopard) and did not browse before the update, I was sur the Update was the culprit here. But the problem you report on the same day (Tuesday June 11) has me thinking Videotron might no be aware there is a problem. OK my machine is way older than yours (Late 2006 white Inter iMac with Snow Leopard 10.6.8) but same exact problem same day with the same exact provider. Hmm, may not be Apple after all. Let's check this tomorrow Wednesday.
     
  4. Tikatika macrumors 6502

    Tikatika

    Joined:
    Mar 12, 2012
    Location:
    Northern California
    #4
    Wow! I had the exact same problem this morning on my 1 week old 21.5 iMac. It was far worse than dial up.

    The only difference? I'm in Northern California, not eastern Canada!
     
  5. Racineur macrumors regular

    Racineur

    Joined:
    Jun 11, 2013
    Location:
    Montréal, Québec
    #5
    Was helped to find a solution

    Hello again. Small world isn't it? Called yesterday night mi ISP (Videotron). My line was tested and all came out fine. The tech suggested I unplug the iMac then the high speed modem. Wait some time. Then plug back the iMac without turning it on. Plug back the modem and wait until all the lights come on. Then boot the Mac and...see. Results (for me though): pages load at normal zippy speed I had before the update. Maybe you too could try this. Get back to the thread to let us know hot it went. Good luck and "Bonne journée".
    Cheers.
     
  6. suparobg thread starter macrumors newbie

    Joined:
    Mar 3, 2013
    #6
    slow internet speeds

    i think it could have been the weather. Today its back to normal.
    Thanks to all who replied
     
  7. cocky jeremy macrumors 68040

    cocky jeremy

    Joined:
    Jul 12, 2008
    Location:
    Columbus, OH
    #7
    It's best to assume the problem is on your ISP's end if all pages are going slow. That's how it is for me, at least.
     

Share This Page