Slow Internet using DNS 4.2.2.x or OpenDNS- speed is fine on PC

Discussion in 'macOS' started by pedalpete, Nov 2, 2009.

  1. pedalpete macrumors newbie

    Joined:
    Nov 2, 2009
    #1
    I'm absolutely struggling with getting a decent connection speed on my mac.

    This started happening a few weeks ago and haven't been able to get it sorted after MANY hours of searching, restarting, recreating connections, etc. etc.

    There are three computers in the house. 1 PC, 2 Macs.
    The PC and the older Mac 1.3 have no problem with connection speed, getting 5Mb/s downloads ans 0.75Mb/s uploads.

    The other mac is 10.5 with all the updates.
    It is currently getting 0.28Mb/s Download and 0.66Mb/s Upload.

    I've the OpenDNS or 4.2.2.x entries in the DNS, and that hasn't fixed the problem. The older mac does not use these entries and it still connects fine.

    Strangely, Skype works with full video and no issues with connectivity, which makes me think that some ports are able to get more than the 0.28Mb/s download, as I doubt I would get Skype video at such slow speeds.

    I've tried FF and Safari, both crazy slow.

    I don't have access to the WiFi base-station, but clearly it is working fine because both of my other computers are connecting to the internet without a problem.

    Please, can somebody provide me with a new direction? I'm running out of options, and there is no Mac store within 200 miles of where I live.
     
  2. wilsonhaven macrumors member

    Joined:
    Oct 12, 2009
    #2
    Check the TCP Settings...

    I just fixed my internet tcp settings and improved the streaming media performance. It seems the default settings for the tcp receive window size and other settings are fairly conservative to newer systems.

    I added this to the end of my /etc/sysctl.conf settings as follows:

    Code:
    ## increase TCP max buffer size setable using setsockopt()
    net.core.rmem_max = 16777216
    net.core.wmem_max = 16777216
     ## increase Linux autotuning TCP buffer limits
     ## min, default, and max number of bytes to use
     ## set max to at least 4MB, or higher if you use very high BDP paths
    net.ipv4.tcp_rmem = 4096 87380 16777216
    net.ipv4.tcp_wmem = 4096 65536 16777216
     ## don't cache ssthresh from previous connection
    net.ipv4.tcp_no_metrics_save = 1
    net.ipv4.tcp_moderate_rcvbuf = 1
     ## recommended to increase this for 1000 BT or higher
    net.core.netdev_max_backlog = 2500
     ## for 10 GigE, use this, uncomment below
     ## net.core.netdev_max_backlog = 30000
     ## Turn off timestamps if you're on a gigabit or very busy network
     ## Having it off is one less thing the IP stack needs to work on
     ## net.ipv4.tcp_timestamps = 0
     ## disable tcp selective acknowledgements.
    net.ipv4.tcp_sack = 0
     ##enable window scaling
    net.ipv4.tcp_window_scaling = 1
    You may want to check a freebsd site for confirmation. This works on my fedora 11 notebook.
    IHTH :)
     

Share This Page