Slow Internet?

Discussion in 'Mac Basics and Help' started by KeepFishing, Jun 29, 2009.

  1. KeepFishing macrumors newbie

    KeepFishing

    Joined:
    Jun 29, 2009
    Location:
    San Marcos, CA
    #1
    Forgive me; I'm new to Macs and pretty ignorant about computers in general, but I've been having problems with Internet on my new computer.
    Pages load slowly or not at all, and sometimes they stop loading midway. I can't watch videos or stream any kind of music without it not loading completely. I tried searching for help and read that I could fix it by changing numbers in Network Settings under DNS Servers, but there's a number there already that I can't delete.
    ANYway, it's a MacBook 5.2 with OS X 10.5.6
    Any help would be greatly appreciated!
     
  2. KeepFishing thread starter macrumors newbie

    KeepFishing

    Joined:
    Jun 29, 2009
    Location:
    San Marcos, CA
    #2
    Oh, and it's wireless Internet. Annnd I've had the problem ever since I got the computer, a few weeks ago.
     
  3. John Doe 57 macrumors 65816

    John Doe 57

    Joined:
    Jan 26, 2008
    Location:
    Los Angeles, CA
    #3
    1. Download OnyX (a free maintenance utility).
    http://www.macupdate.com/info.php/id/11582

    2. Open OnyX and Click Cancel on these two Alert Panels:
    -Cancel the S.M.A.R.T. Box
    -Cancel the Startup Volume Box

    3. Enter your Password

    4. Click on the Cleaning Tab

    5. In each tab, within the Cleaning Tab, execute the command. Check all the boxes in each tab. When its finished in that tab, it will ask you to reboot. Say NO. Go on to the next tab and repeat until all tabs, within the Cleaning Tab, are done. THEN REBOOT.
     
  4. KeepFishing thread starter macrumors newbie

    KeepFishing

    Joined:
    Jun 29, 2009
    Location:
    San Marcos, CA
    #4
    I tried it yesterday and again today.. still slow :(
     
  5. MacManiac76 macrumors 65816

    MacManiac76

    Joined:
    Apr 21, 2007
    Location:
    Arizona
    #5
    Try adding the OpenDNS servers (208.67.222.222 and 208.67.220.220) to your DNS settings in Network Preferences. Click the plus sign at the bottom to add the new servers to the listings. The one you can't delete should be the local address of your router. You can also change the DNS server settings of your router to these same OpenDNS servers if changing them in the OS X Network settings doesn't seem to help. Give it a shot and let us know if this helps at all.
     
  6. NP3 macrumors regular

    Joined:
    Jul 12, 2003
    Location:
    Los Angeles
    #6
    Have a friend over and see if it does it on their computer as well.

    Also check to make sure your wireless router is password protected with WPA2 security. A neighbor might be sucking up all your bandwidth.

    I noticed you're running 10.5.6: (10.5.7 is current) Have you run Software Update yet on your new computer? I think there's been an airport update or two lately. Its found in System Preferences as well. Onyx probably wouldn't help you, as a couple weeks really isn't enough time to build up the crap that can slow things down like that.

    If none of these work, and your friends is slow as well, contact your provider, its probably them.
     
  7. iAlexG macrumors 6502

    iAlexG

    Joined:
    Jun 15, 2009
    Location:
    Florida, Missing Britain.
    #7
    Contact your service provider. They may be doing maintenance. Comcast do that a lot!!!
     
  8. KeepFishing thread starter macrumors newbie

    KeepFishing

    Joined:
    Jun 29, 2009
    Location:
    San Marcos, CA
    #8
    My mom has a PC and the Internet works fine on her computer. And yesss, it's password protected.
    I did the software update and the DNS number thing, and it seems better! Or maybe it's just my imagination? Everything is loading quickly; videos still don't completely but that isn't reaaally important.
     
  9. NP3 macrumors regular

    Joined:
    Jul 12, 2003
    Location:
    Los Angeles
    #9
    If videos aren't working quite right go to adobe.com and make sure you have the latest flash player installed. That's the only other thing I can think of!
     
  10. davelanger macrumors 6502a

    Joined:
    Mar 25, 2009
    #10
    What browser are you using? Did you try using fire fox?
     

Share This Page