Slow or no loading of http pages

Discussion in 'Mac OS X Server, Xserve, and Networking' started by DrNo, Jan 31, 2017.

  1. DrNo, Jan 31, 2017
    Last edited: Jan 31, 2017

    DrNo macrumors newbie

    Joined:
    Aug 10, 2009
    #1
    Hi,
    I have a 2014 Macbook Pro and I've been experiencing on and off a very annoying slow loading of web pages. They take tens of seconds to load, and in most cases the browser just gives up and displays the error message "There is no internet connection", "The site can't be reached" or "is taking too much time to respond". Here are some facts:

    1. It happens with ALL my browsers (Chrome, Safari, Firefox), on ALL the networks I tried (home, work, cafes, you name it...), and as far as I can tell on ALL webpages.

    2. The problem usually lasts for a few days, then it works correctly for a while, then it stops again for a few days, and so on.

    3. It happens both with WiFi and with Ethernet connection.

    4. The data transfer speed of the Wifi and Ethernet seems fine:
    - speedtest.py run from the terminal gives Download 49.67 Mbit/s, Upload 5.43 Mbit/s.
    - I also measured the speed directly by downloading a 80Mb file, it took less than a minute with Wifi.

    5. I have no problem using ssh and scp from the terminal and they work as expected. On the other hand if I try to load a webpage from the terminal using wget I get the same slow loading. So I suspect the problem is with http.

    6. I have an iMac on my home network and I never experienced this problem on the iMac. When connected to the home network, the iMac and the Macbook use the same DNS servers.

    7. I tried using the Google Public DNS servers it does not changing anything.

    8. Closing and reopening the browser or the connection doesn't do anything. Restarting the computer sometimes, but not always, resolves the problem temporarily.

    Any help greatly appreciated.
     
  2. belvdr, Jan 31, 2017
    Last edited: Jan 31, 2017

    belvdr macrumors 603

    Joined:
    Aug 15, 2005
    Location:
    No longer logging into MR
    #2
    If this happens regardless of network location (i.e. home, work, etc) and connection (i.e. wired and wireless), then this points to software on the computer causing issues.

    Do you have any type of antimalware, firewall, or caching software loaded? Running curl/wget from Terminal eliminates the browser. This is system level software.
     
  3. DrNo thread starter macrumors newbie

    Joined:
    Aug 10, 2009
    #3
    Thanks. I don't have a firewall. I do have Sophos antivirus installed but I tested that when I temporarily disable it, the problem persists. I don't know what caching software is.
     
  4. belvdr macrumors 603

    Joined:
    Aug 15, 2005
    Location:
    No longer logging into MR
    #4
    I'd uninstall the Sophos software and retest. Software is your issue, as you've eliminated networking entirely.

    I had issues with Symantec Endpoint Protection a couple of years ago, because it had a network threat protection module that was causing issues. Disabling it had no effect, but uninstalling it solved the issue.
     
  5. DrNo thread starter macrumors newbie

    Joined:
    Aug 10, 2009
    #5
    I did a scan with malwarebytes and eliminated a few threats. Right now it's working correctly (Sophos still installed), I keep my fingers crossed...
     

Share This Page