Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

HarryPot

macrumors 65816
Original poster
Sep 5, 2009
1,012
400
Hi,

Ever since updating to High Sierra editing photos has been a terrible experience.

Navigating the app and opening photos works fast as always. But just clicking the Edit button completely breaks the app.

It takes around 4-5 seconds to load the first image and be able to adjust something. Then, after making the first adjustment, the app stops again and it takes another 4-5 second to respond again.

I don't have the newest Mac (MBP 15" Late 2011, 16GB RAM and SSD), but editing photos in Lightroom, Aperture, Affinity Photo, Photoshop works perfectly.

What could be causing this behavior in the Photos app?

I appreciate any help!


EDIT: I just found something. Editing JPEG files works extremely well. My files are RAW from my Nikon D300 (12MP).

Could it have something to do with how Photos is handling my RAW files?
 
Last edited:

v3rlon

macrumors 6502a
Sep 19, 2014
753
522
Earth (usually)
I wouldn't think off the bat.
I am using a Mac Pro (2009), SSD, R9 280 video card, and the photos are actually on a spinning disk. My D750 raw files come up fine. they take a bit to import, but editing and switching between them is fine. One of the main reasons I like Photos is how fast it is.
 

HarryPot

macrumors 65816
Original poster
Sep 5, 2009
1,012
400
I'm thinking about doing a Clean Install... but doing so requires so much time :(
 

HarryPot

macrumors 65816
Original poster
Sep 5, 2009
1,012
400
Affinity Photo only. I already removed it and there was no change.
[doublepost=1512578701][/doublepost]Ok, I guess I'm closer to finding my problem.
Photos taken with my Nikon D40x (10MP RAW) work perfectly, no lag at all.

Photos from my D300 are the problem. What could it be?
I already tried with the three formats (Compressed, Lossless Compressed and Uncompressed; 12-bit and 14-bit). No matter the format editing is terribly slow.
 

Fishrrman

macrumors Core
Feb 20, 2009
22,991
8,756
"I don't have the newest Mac (MBP 15" Late 2011, 16GB RAM and SSD), but editing photos in Lightroom, Aperture, Affinity Photo, Photoshop works perfectly.
What could be causing this behavior in the Photos app?"


If all the other apps "work perfectly", then I'll guess that whatever problems you're running into ARE NOT "in hardware".
I don't think a "clean install of the OS" will make a difference, either.

It's something with the Photos app vs. the RAW files from the Nikon.

Just wondering, do you happen to have another camera?
That can do RAW, as well?
Can you import some of those pics into Photos in RAW format?
Does it still run poorly with them, also?
If not, can you download somebody else's RAW images from somewhere?
Can you try editing them in your copy of Photos?
Do you still have the same slowdowns?
 

HarryPot

macrumors 65816
Original poster
Sep 5, 2009
1,012
400
Files from my D40x work very well in Photos.

I downloaded some RAW files from a D700 (12mb) online, and it was slow. Just as slow as my D300 files. Editing in Affinity Photo works fast.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.