Slow response

terrycard

macrumors newbie
Original poster
Jun 6, 2015
8
0
How to fix slow response time. Watch is continually on a clock. Please help!
 

terrycard

macrumors newbie
Original poster
Jun 6, 2015
8
0
It doesn't show on watch face. When you go into glances its on a clock. On watch face it just shows 2 spaces with no numbers. It does the same thing for stocks in glances. I tried turning watch off & back on. No change.
 

GrumpyMom

macrumors G3
Sep 11, 2014
8,690
12,408
It doesn't show on watch face. When you go into glances its on a clock. On watch face it just shows 2 spaces with no numbers. It does the same thing for stocks in glances. I tried turning watch off & back on. No change.
I'm sure many of us would like to help you but it is very unclear what your problem is. What watch face are you looking at?

How much reading have you done about how Apple watch works? Have you viewed the instructional videos on the Apple site yet?

Have you paired your watch to your iPhone successfully yet? I'm sorry I really don't know what you mean when you say "it doesn't show on watch face". What is "it"? The time?

Edit to add, I have to be leaving now for some weekend events. In the meantime if you could explain to us how far along you are in setting up your Apple Watch, that would help give us a reference point from which to give you better advice. Forgive me if I'm mistaken, but it sounds like you've just gotten it and are in the initial stages of setting it up to display everything you want it to. Again I apologize if I am mistaken but you've not told us enough to go on.

Oh, and welcome to the forum. Your avatar dog is very cute.
 
Last edited:

terrycard

macrumors newbie
Original poster
Jun 6, 2015
8
0
I have the 42 mm ss Milanese band. I'm using Mickey with weather as 1 of the complications. I have had the watch for several weeks. It's paired with iPhone 6 plus & everything is set up. When you go into the weather app included with the watch it stays on a clock. It worked fine until yesterday. It does the same thing with the stocks app. I appreciate any help.
 

GrumpyMom

macrumors G3
Sep 11, 2014
8,690
12,408
Sound like OP has apps failing to launch. Try a hard restart?
Yeah that sounds like it to me, too.

Do you think rebooting the watch by pressing down on the crown and the side button simultaneously will suffice or should Terrycard reboot his/her phone as well? I've not run into this particular problem myself yet.
 

terrycard

macrumors newbie
Original poster
Jun 6, 2015
8
0
Thanks for all your help. I went to Apple store & they unpaired watch & paired again & it worked. They had never seen this problem before either.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.