Slow Safari Page Loads New MBP TB

Discussion in 'MacBook Pro' started by rkdiddy, Nov 29, 2016.

  1. rkdiddy macrumors 65816

    rkdiddy

    Joined:
    Mar 19, 2008
    Location:
    OC Baby!
    #1
    I'm curious is anyone else seeing slow page loading in Safari on the new MBP w/ TB? I've noticed with my new MBP that pages seem to take a long time to load - slower than my older MBP. This happens both when I enter the URL and it's fetching the site and when clicking on individual pages. I've also noticed that the buttons (links) sometimes are last to populate or are unresponsive causing me to have to reload the page.

    Is anyone else having this issue?


    Not my internet speed.
    Ping: 11 ms
    Download: 335.31 Mbps
    Upload: 32.19 Mbps
     
  2. Grolubao macrumors 65816

    Grolubao

    Joined:
    Dec 23, 2008
    Location:
    London, UK
  3. Marshall73 macrumors 65816

    Marshall73

    Joined:
    Apr 20, 2015
    #3
    Turn off search suggestions, turn off preload top result etc, speeds up safari In general.
     
  4. dashwin macrumors regular

    dashwin

    Joined:
    Sep 19, 2015
    #4
    For me Safari scrolling is worse off overall and loading images that aren't on screen appears slower than my early 2011 MBP. Safari remembered passwords loads are a lot slower I have noticed too.

    So yes, there appears to be some sluggishness oddly on my maxed out MBP 15" with TB. Not entirely sure yet what is going on.
     
  5. Low country macrumors 6502

    Joined:
    Feb 6, 2016
    Location:
    South Carolina
    #5

    Scrolling in Safari on a maxed out 13" TB is bad here, for example two finger scrolling through the forums at Macrumors is kinda jittery. Also seeing lag or skipping in dock animations and scrolling through the applications folder but I see NO lag scrolling through all my photos in the photos app.

    I have pre load top hits disabled as well as safari search suggestions...

    Headed to the Genius Bar tomorrow
     
  6. BasicGreatGuy Contributor

    BasicGreatGuy

    Joined:
    Sep 21, 2012
    Location:
    In the middle of several books.
    #6
    Bought a 13" base touch bar yada, yada, yada. Haven't experienced any slow scrolling or response from Safari. I did do a fresh install of Sierra after my purchase.
     
  7. thesaint024 macrumors 65816

    thesaint024

    Joined:
    Nov 14, 2016
    Location:
    suspension waiting room
    #7
    Not that I've noticed, but ironically I would be thrilled if this were a bug. Because it would mean Safari would be faster in some future update.
     
  8. Low country macrumors 6502

    Joined:
    Feb 6, 2016
    Location:
    South Carolina
    #8
    Tried to upload a short 21 second video I took with my 7+ showing scroll lag on MBP....Unable to upload...any ticks to making this work?
    Thanks
     
  9. rkdiddy thread starter macrumors 65816

    rkdiddy

    Joined:
    Mar 19, 2008
    Location:
    OC Baby!
    #9
    Mine is maxed out as well. I was searching for a hotel and noticed that the buttons/links on the page just stopped working all together. I had to reload the page to get them to work again. Very strange.


    Please keep us posted on how it goes. I would imagine it would be a software issue, but seriously considering returning my machine to try my luck on another. Hoping it's not a graphics issue.
     
  10. Low country macrumors 6502

    Joined:
    Feb 6, 2016
    Location:
    South Carolina
    #10
    Will do George.. LOL
     
  11. wchigo macrumors 6502

    wchigo

    Joined:
    Apr 6, 2015
    #11
    Haven't had any issues with this on the base 13" non-TB model. Any weirdness I've encountered usually had more to do with the hotel wifi rather than any issues of the computer itself...
     
  12. myscrnnm macrumors 65816

    myscrnnm

    Joined:
    Sep 16, 2014
    Location:
    Seattle, WA
    #12
    I have noticed this with Safari on my 13" 2016 MacBook Pro as well. The bar will load around one-sixth of the way, pause for several seconds, and then the page will load on several webpages.
     
  13. Odorcide macrumors newbie

    Joined:
    Nov 17, 2013
    #13
    I'm having the same issue but it seems if I restart the computer it speeds up.
     
  14. MrGuder macrumors 68020

    Joined:
    Nov 30, 2012
    #14
    Just wondering if an ad blocker installed could be the issue?
     
  15. Odorcide macrumors newbie

    Joined:
    Nov 17, 2013
    #15
    Not it my case, I uninstalled all safari extensions and deleted all cookies and cache.
     
  16. Odorcide macrumors newbie

    Joined:
    Nov 17, 2013
    #16
    I just experienced a slow down on safari and turning off wifi and turning it back on help immediately.
     

Share This Page