Slow shutdown on macOS 10.12 Beta GM

Discussion in 'macOS Sierra (10.12)' started by vunguyenhung, Sep 9, 2016.

  1. vunguyenhung macrumors newbie

    vunguyenhung

    Joined:
    Sep 9, 2016
    #1
    Hi there, I just updated my macbook pro mid 2015 to macOS 10.12 this morning and found my mac shutting down time is incredibly slow. It takes about 10 minutes to shutdown or restart. Does anyone face this issuse?
     
  2. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #2
    Do you have a hard-drive or an SSD in your Mac? What year/model/specs is your machine please?
     
  3. vunguyenhung thread starter macrumors newbie

    vunguyenhung

    Joined:
    Sep 9, 2016
    #3
    my macbook is using SSD hard-drive. This is my specs
    upload_2016-9-9_20-11-21.png
    Thank you for quick reply
     
  4. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #4
    Hmm, very odd. You can try the following:

    1) Reset PRAM by holding CMD + ALT + P + R on startup, until you hear the Apple boot chime 3 times, then let go.

    2) When shutting down or restarting, ensure the checkbox for 'reopen windows when logging back in' is disabled/unticked.

    3) Ensure all apps are completely closed before trying to shut down. You can do this by pressing CMD + TAB to see the open apps, and press CMD + Q to close the apps. You won't be able to close Finder, but everything else should close fine.

    You can also try run 'First Aid' on the disk through Disk Utility, to see if that identifies any issues. Please let us know how you get on!

    Best wishes and speak with you soon.
     
  5. aqeelb macrumors newbie

    aqeelb

    Joined:
    Sep 9, 2016
    Location:
    Singapore
    #5
    I have the same problem and I can feel the lag on my iMac
     

    Attached Files:

  6. vunguyenhung thread starter macrumors newbie

    vunguyenhung

    Joined:
    Sep 9, 2016
    #6
    Hi, I tried to reset PRAM but the problem is still there. I also run 'First Aid' but no issue found. There's only finder is opening when I shut it down. And unfotunately I forgot to use time machine to backup my mac :'(
     
  7. adrianlondon macrumors 6502a

    Joined:
    Nov 28, 2013
    Location:
    Switzerland
    #7
    I had the same issue yesterday evening right after I installed the GM, but only on shutdown. Booting was a fast as always. I had to reboot a few times (as I needed to disable SIP and re-install SIMBL) so it was irritating. However, this morning my shutdown speeds are back to normal (ie fast).
     
  8. vunguyenhung thread starter macrumors newbie

    vunguyenhung

    Joined:
    Sep 9, 2016
    #8
    Yes, my mac does anything else just fine except shutdown, I don't know what's the cause of this issue. If it like you said, maybe I just wait until tomorrow and hope the magical thing happened :'(
     
  9. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #9
    I'm sorry to hear that. Seems like you're not alone with the issue though, so possibly an OS bug (as it's still in beta).

    A few more things you can verify: disable/delete some login items through System Preferences, empty Trash, check free space on your drive... also check Software Updates, on the off chance there might be some update silently released.
     
  10. vunguyenhung thread starter macrumors newbie

    vunguyenhung

    Joined:
    Sep 9, 2016
    #10
    After updating, my disk space has 40GB larger and I don't know why, but I think it's a good thing. The problem is still there but thank you for your help! I'm very appreciate it!
     
  11. xgman macrumors 601

    xgman

    Joined:
    Aug 6, 2007
  12. KingDavid macrumors newbie

    Joined:
    May 3, 2011
    #12
    I had this issue, and tracked it down to MySql. I prevented it from starting automatically, and then stopped the MySql service (which took about ten minutes to do, and made System Preferences seem unresponsive). After that, everything started working okay again.

    I'm thinking I'm going to uninstall it. I have no clue why it's installed to begin with.
     
  13. vunguyenhung thread starter macrumors newbie

    vunguyenhung

    Joined:
    Sep 9, 2016
    #13
    Yes, my issue is still there. Thank you for mentioning it, I'm not shutdown my mac yet 'cause I have some more works to do. But actually, I have mySQL on my machine too, I just checked again and it seems to be broken. I'll make a post in this threads if the issue is solved. Thank you for your help !
     
  14. vunguyenhung thread starter macrumors newbie

    vunguyenhung

    Joined:
    Sep 9, 2016
    #14
    Thank you!! I unchecked "Start on Startup" on MySQL Preference and then the problem is solved. Thank you soo much for helping me !!!!
     
  15. otech macrumors newbie

    Joined:
    Jul 9, 2012
    Location:
    Australia
    #15
    You guys just solved my shutdown issue too (Sierra Public Release) - thanks!

    We should probably file a bug with MySQL...
     
  16. Jonnyprue macrumors newbie

    Jonnyprue

    Joined:
    Sep 23, 2016
    #16
    I have exactly the same problem, I've been working with Apple support on twitter for two days now. Creating new user accounts, PRAM clearing and safe mode. Issue resolved in safe mode but still no closer to the root cause.
     
  17. Ih8reno macrumors 65816

    Ih8reno

    Joined:
    Aug 10, 2012
    #17
    Mac Pro 4,1 flashed to 5,1. Shutdown takes a long time I can even leave the room for awhile and when I come back it's still on a black screen with curser. So frustrating
     
  18. wl33thompson macrumors newbie

    wl33thompson

    Joined:
    Mar 1, 2017
    #18
    Thanks for keeping asking questions, although I solved the problem by a method not as same as yours that is suggested by someone.

    The approach I used is starting my computer and then releasing the pressing. After that, keep pressing Command + Option +R +P synchronously and hold them until I hear 4 sound of restarting.

    After that, magic appeared and my computer shut down as fast as usual.
     

Share This Page