Slow speed Samsung 840 SSD iMac 20" - Fixed?

Discussion in 'iMac' started by jeroenvermeulen.nu, Apr 14, 2016.

  1. jeroenvermeulen.nu macrumors newbie

    Joined:
    Jun 29, 2015
    #1
    Hi,

    I have a iMac 20" here with a Samsung 840 SSD, my neighbor told me it was very slow.
    On OSX 10.10 I used the application Disk Speed Test, the results were bad, 67 MB/s read, 260 MB/s write.
    I tried to update the firmware with the Samsung ISO on their website, I failed.
    The CD won't boot properly, a known issue on the internet.

    Thatswhy I installed Windows 7 with Bootcamp.
    To my surprise it told me it was on the latest firmware.
    I tested with Samsung Magician the speeds, it was correct now, 250 MB/s read and write.
    I booted up OS X again, and now the speeds are correct! 220 MB/s read and 270 MB/s write.

    Could somebody explain to me what happend?

    Thank you.
     
  2. h9826790 macrumors 604

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #2
    The slow read issue was fixed long time ago. What's your firmware version now?
    Screen Shot 2016-04-15 at 05.54.58.jpg
     
  3. jeroenvermeulen.nu thread starter macrumors newbie

    Joined:
    Jun 29, 2015
    #3
    Revision DXT09B0Q
     
  4. Samuelsan2001 macrumors 603

    Joined:
    Oct 24, 2013
    #4
    Windows automatically supports TRIM so when you booted to Windows TRIM was enabled and sorted out your SSD. You can use trim enabler to enable it in OS X or you can just boot to Windows occasionally to perform this maintenance.
     
  5. h9826790 macrumors 604

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #5
    That's the current firmware
     

Share This Page