Slow speed test results on wifi. iPhone and iPad.

Discussion in 'iOS 10' started by t76turbo, Oct 23, 2016.

  1. t76turbo macrumors regular

    Joined:
    Sep 20, 2012
    #1
    iPhone 6s+ (and iPad Pro 9.7). Both with 10.0.2. Under previous versions of the iOS I routinely got 85-92 Mbps on my iPhone and iPad on my home network. I have cable modem service and using a Netgear Nighthawk r7000 router.

    Recently I had some random disconnects on my laptop and ran a speed test just out of curiosity on my iPhone. I used the Speedtest app and the Netflix Fast app and am only getting in the 22-31 Mbps range consistently. Tried it many times at different times of the day with same results. I opened my laptop at the same time and used either my isp's speed test page or the Speedtest website (or both) and still get upper 80's to low 90's.

    I have rebooted the phone and iPad with no impact. I have no QoS or other traffic prioritization turned on in the router.

    Has anyone else seen similar results or have any tips on ways to improve this?

    I don't recall running speedtest since the upgrade to ios10 so I am assuming it could have happened with the upgrade.
     
  2. dictoresno macrumors 601

    dictoresno

    Joined:
    Apr 30, 2012
    Location:
    NJ
  3. JasonHB macrumors regular

    Joined:
    Jul 20, 2010
    Location:
    Warwickshire, UK
  4. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #4
    Sounds more like a router issue than an issue with your devices given the disconnects.

    As above reboot it. If all else fails restore it to factory defaults
     
  5. t76turbo thread starter macrumors regular

    Joined:
    Sep 20, 2012
    #5
    Sorry for not including that info.

    I actually believe the disconnects are my laptop or the cable service. There was an partial outage in my area so they wouldn't send a tech to test the wiring up to my home. But they blamed my cable modem for the disconnects due to age so I replaced it. Happened to have a spare new one from a previous problem. That didn't fix it.

    I have tested in both frequencies. Low speeds on both frequencies on the iOS devices but the same high speeds on my laptop when I test it.

    Rebooted the router multiple times. Went back to an older firmware which didn't help. Upgraded back to the newest with no change.


    I would certainly blame the router if I wasn't getting the correct speeds on the laptop.
     

Share This Page