Slow to wake up from sleep

MPB11

macrumors regular
Original poster
Feb 2, 2011
150
0
Hey guys,

So I upgraded to ML yesterday, I am running a quadcore i7 2.2 early 2011 mbp. I have noticed that since the upgrade my laptop is SO FU*#@$ slow to wake up from sleep, and I'm not talking when I close the lid, I'm talking about when it goes out after 5 minutes of inactivity...I takes a lot of time to quit the screen saver mode, couples of more seconds to type my password, little beach ball, couples of seconds to come back to life, little beach ball and THEN I'm back...that's my only downpoint regarding ML so far.

does it affect you 2 guys?
 

scharah

macrumors member
Jan 15, 2008
50
1
having the same problem, tapping/dragging on the trackpad doesn't seem to be enough to wake it, I have to actually click. And even then it takes a while.
 

MPB11

macrumors regular
Original poster
Feb 2, 2011
150
0
having the same problem, tapping/dragging on the trackpad doesn't seem to be enough to wake it, I have to actually click. And even then it takes a while.
exact same thing for me
 

smogfalls

macrumors newbie
Jul 28, 2012
2
0
I'm also having this issue, although I'm on an iMac...

I have an early 2011 27" iMac with 8gb RAM. I upgraded to Mountain Lion from Snow Leopard this morning. Everything went perfectly except for this one annoying issue! I can't track down what may be causing the problem.

Any advice would be greatly appreciated. Will let you know if I figure anything out. At first I assumed it could be Time Machine slowing things, but even after ejected that drive and restarting, it's still taking around 20 seconds to wake from sleep... it's pretty frustrating.

Cheers,
Xan
 

MPB11

macrumors regular
Original poster
Feb 2, 2011
150
0
I believe I fixed the problem but can't be 100% sure yet. Anyways, what I did is I went into system preferences, and change the Energy saving settings. My HDD used to go to sleep after 15 minutes of inactivity (at the same moment as my screen saver kicked in), I pushed it to 2 hours of inactivity and It never bugged me again, It's even faster than with SL to wake up now. I guess ML has yet a hard time with waking up the HDD. Let me know if it helped u guys.
 

Arelunde

macrumors 6502a
Jul 6, 2011
980
28
CA Central Coast
I believe I fixed the problem but can't be 100% sure yet. Anyways, what I did is I went into system preferences, and change the Energy saving settings. My HDD used to go to sleep after 15 minutes of inactivity (at the same moment as my screen saver kicked in), I pushed it to 2 hours of inactivity and It never bugged me again, It's even faster than with SL to wake up now. I guess ML has yet a hard time with waking up the HDD. Let me know if it helped u guys.
Thanks! Normally, my late 2011 MBP 13 wakes instantly (amazingly fast on ML) when I open the cover. Every once in a while, though, it takes a while to wake up. The screen is black behind the login window (that I authorized) in these cases, rather than the screen saver. I didn't think of the "sleep" factor. Will change that. Again, thanks.

Edit: I checked the power saver settings and realized I had the screen to sleep at 1/2 hour and the sleep at 3 hours. I changed both to 3 hours since I usually shut the cover when I'm not using the MBP.
 

EDx

macrumors newbie
Jul 28, 2012
4
0
Sleep Fix

Yo ho ho!

I too had this problem but I fixed it with an SMC Reset.

Now its even quicker than ever!

http://support.apple.com/kb/HT3964

Here is an apple link, I skipped the 'before you reset' stuff and dived right in!

... If you are the cautious type tho, follow this properly!

Safe
 

PatriotInvasion

macrumors 68000
Jul 18, 2010
1,525
570
Boston, MA
I've noticed this too. Almost did a hard restart until I heard some noises inside my iMac. 10 seconds later it awoke. A bug that will be fixed in 10.8.1 I'd imagine. Stay calm...
 
L

lukemcurley

Guest
I have this problem too with a MacBook Air (late 2010). When my Mac is asleep and I open the lid, the login screen shows but I cannot enter my password or move the mouse for up to 5 seconds.
 

EDx

macrumors newbie
Jul 28, 2012
4
0
I've noticed this too. Almost did a hard restart until I heard some noises inside my iMac. 10 seconds later it awoke. A bug that will be fixed in 10.8.1 I'd imagine. Stay calm...
Why is no one noticing?!

RESET YOUR SMC! Follow the link above for the official apple instructions!!
 

will0407

macrumors 6502a
May 20, 2006
560
12
Why is no one noticing?!

RESET YOUR SMC! Follow the link above for the official apple instructions!!
I've just done this after having the same issues with my 2011 MBA. I'll report back after a couple of days testing

EDIT: just opened the lid after closing for about 90 minutes. Still locked up and had to wait for it to come alive again.
 
Last edited:

emiliofigueroa

macrumors newbie
Jul 31, 2012
1
0
I believe I found a fix.

I went into my Preferences, then security, and changed the require password immediately to require after 5 minutes and that fixed the very slow wakeup. Before this I also changed a setting in the terminal from hybernatemode 3 to 0 which stopped Mac OS from storing the system session on the RAM (you can google that). So hopefully this works for everyone!
 

djdouglas2002

macrumors newbie
Aug 26, 2012
1
0
This worked!

Thanks for the tip! This absolutely worked for me on my iMac. Display returns from sleep in 2s now. Thanks.

----------

Yo ho ho!

I too had this problem but I fixed it with an SMC Reset.

Now its even quicker than ever!

http://support.apple.com/kb/HT3964

Here is an apple link, I skipped the 'before you reset' stuff and dived right in!

... If you are the cautious type tho, follow this properly!

Safe
Worked! Awesome...thanks.
 
Last edited:

WhiskeySour

macrumors newbie
Oct 3, 2007
7
0
My iMac 27 i5 developed the slow wakening after sleep syndrome, SWaSS, and as it is still under Apple Care, I gave them a buzz. Not exactly sure what the tech made me do, but he did have me restart the iMac a couple of times while holding down the Command and R keys. Then he had me unplug all the cords at the back, Power, USB, etc--anything that was plugged into it. I believe he then had me try to start the machine while everything was unplugged--even the Power cord. This apparently cleared any residuals in the iMac (I think that's what he indicated). We then restarted the iMac again (I forget if we used the Command R thing again) and then tried waking it up after sleep.
I was happy to see all the above worked and it's now waking quickly and the iMac even seems a bit faster.
Anyone on here with Tech ability will likely have some idea of the above process?
Cheers
 

WhiskeySour

macrumors newbie
Oct 3, 2007
7
0
Permissions Repaired

One more thing--Also repaired permissions which I normally do anyways with Cocktail.
 

Sesmar

macrumors newbie
Jan 22, 2013
1
0
Slow wakeup

Disconnect the power cable from your MacBook, then reconnect. Voila!
 

wiser2day

macrumors newbie
May 17, 2013
1
0
Resetting the SMC works

Resetting the SMC totally worked for me. Thanks EDx :)

Quick instructions on how to reset the SMC on a MacBook Air:
1. Shut down the computer.
2. Plug in the MagSafe power adapter to a power source, connecting it to the Mac if its not already connected.
3. On the built-in keyboard, press the (left side) Shift-Control-Option keys and 4. the power button at the same time.
5. Release all the keys and the power button at the same time.
6. Press the power button to turn on the computer.
Note: The LED on the MagSafe power adapter may change states or temporarily turn off when you reset the SMC.

Source: http://support.apple.com/kb/HT3964
 

cosmicjoke

macrumors 6502
Oct 3, 2011
484
1
Portland, OR
i think your macbook is going into standby.... if you do a pmset -g from terminal you'll see the standbydelay timer which is 4200 (seconds)... so in 1hr & 10 mins after sleeping the mac goes into standby, which uses even less power and allows the mac to potentially stay in that state for up to 30 days before draining the battery... the downside is it's slower to wake when it's in standby....

you can change the standbydelay to something else though

e.g.

sudo pmset -a standbydelay 43200

that would be 12hrs before going into standby, 86400 for 24hrs etc.... whatever you change it to it will wake up that snappy until after that amount of time has elapsed.