Slow when downloading apps over wifi- iPhone 5

Discussion in 'iPhone' started by patrikkoo, Oct 3, 2012.

  1. patrikkoo macrumors newbie

    Aug 19, 2011
    Does anyone have problems when downloading apps over wifi on the iPhone 5? Everything else works fine when using the phone (Browsing the internet, youtube, etc). Just when downloading apps. It takes 10-15mins when downloading apps that is less than 10MB.

    This is strange because when I download iphone apps from my macbook via iTunes, it is always fast. They are both connected to the same wifi router, which is a Linksys EA4500 and I'm very sure that the internet speed is not an issue.

    Tried setting up the router with no encryption too, but still no luck.

    Please help :(
  2. iApache macrumors 6502


    Jun 20, 2010
    Just yesterday I bought the EA4500 router, as soon as I set it up, my iphone was VERY slow. After a few minutes, it went back to normal, it was actually faster then my previous router. Have you tried this method?

    On my previous iPhone 4S, I had wifi issues and when I did the manual DNS it worked perfect for me. Hope this helps!
  3. RiSC123 macrumors newbie

    Oct 13, 2012
    I have the same problem. The internet speed is fine and I measure good results with the app. Just App downloads are terrible slow with iPhone 5. To download a 5MB App it needs several seconds with the iPhone 4 and arround 3 minutes with my new iPhone 5. :(

    I tested several configurations on my Router d-Link DIR-655.
    Tested G and N with different encryptions (WEP, WPA with TKIP and AES) and uncrypted, 20 and 40 MHz, different channels...
    No luck on my side.

    At work with a different AP the App dowloads is fast.
  4. vidinoz macrumors newbie

    Dec 2, 2012
    Tried Everything

    Hi All,

    I have a Netgear WNDR3700 and DM111P combo - both with the latest firmware.

    I too have tried (on the Router):

    a/b/g/n combinations
    WEP, WPA etc combinations
    Channel 6 / auto combinations
    20 / 40 MHz combinations
    Enabled / dissabled SSID + changed SSID
    Un-setting the static IP for the phone and allowing DHCP to control things
    Enabled IPv6
    Turned on/off guest network - different settings as above
    Ensured DHCP only active on one device so no conflicts
    Run multiple network diagnostics and check for interference
    Turned of QoS

    I too have tried (on the iPhone 5) running 6.0.1:

    Using DHCP /static wi-fi settings
    Turning on auto proxy with the URL blank
    Changind the DNS to Google or
    Power cycling the phone
    Hard resetting the phone
    Resetting the Network settings only
    Completely wiping and restoring the phone
    Deleting and re-installing FB app - and not logging in
    Logged out and back into iTunes

    Still - after about 50 different combinations of settings, wi-fi is perfectly fine, but app downloads are woefully slow.

    My old 4 (now my wife's) is completely fine. Downloading apps over 3G, fine. Downloading apps on my work's enterprise network, fine.

    Last resort was to swap the phone over with apple which I did at the weekend - still no change.

    Last resort is to pull out my old(ish) Airport Extreme and Express and patch it up just enough to try downloading a new app...

    Otherwise I'm completely out of ideas and hope 6.1 has some hidden update features... :confused:
  5. upnorth85 macrumors 6502a


    Oct 2, 2011
    MN, USA
    I was trying to download from the itunes a video I had purchased (Dexter!) previously. The download took for ever. Several times, I measured the Wi-Fi speed which was above 20 Mbs. But the download of Apps and itunes material takes for ever. I think the problem is at the Apple server end which is probably loaded and the server is having to work hard to keep up with more requests than it can handle. This is not an iPhone or iPad problem at our end.
  6. vidinoz macrumors newbie

    Dec 2, 2012
    I'd have to disagree with you there. As mentioned, my wife's iPhone 4 has no issues.

    We can sit next to each other and download the same app at the same time and her's will complete in no time at all, where as my iPhone 5 will take 15 mins to download the same 10MB app.

    I have also noticed that the wifi reception is not quite as good on my 5 - range is not so good. Also, buffering for YouTube is also slower. Again, no issue with the 4.
  7. vidinoz, Dec 3, 2012
    Last edited: Dec 3, 2012

    vidinoz macrumors newbie

    Dec 2, 2012
    I've set up my AEX quickly tonight and set it up just so I could wireless access the internet and update an app to test DL speeds.

    Although the download wasn't super quick, the app certainly downloaded closer to the 'normal' speeds that I'd expect.

    There must be an issue with routers/firmware out there and the new wireless card in the iPhone 5 - that is to say that routers are not compatible with apples new chip or vice versa. Both routers were connected to my DM111P modem, so it's not a modem issue.

    I'm certainly not going to buy another router right now as 802.11ac should be a standard by next year and I'm hoping the next MBP will carry this natively and will upgrade my router then.

    Let's hope there's a FW update soon from either apple or Netgear; Or iOS 6.1 addresses this in the next week or two.

    Back to the old router now as the AES is just too limited for my needs. If it's only app updates, on wifi, on my iPhone 5 only, then I can live with that for the time being. I'll just update large apps on my mac and sync them across.
  8. vidinoz macrumors newbie

    Dec 2, 2012

    New things tried:

    Told phone to forget my network, then added it manually under 'wifi/other'.

    Set the DNS on my ROUTER back to the defaults from my ISP and not Googles - plus also tried setting my phone DNS back to after the first part made no difference with changing the router settings.

    Uninstalled the Speedtest app.

    Note: I pretty much realise that this will be a software issue due to conflicting hardware with the new network chip in the iPhone 5, but I'm just listing all of the 'reported' fixes and tips I've tried myself and found on numerous other sites to save others trawling through the same amount of crap I have.

    I've read quite a few reports that its mostly Netgear routers having the issues at the moment... Still waiting for new FW from either Apple or Netgear.
  9. Risco macrumors 68000


    Jul 22, 2010
    United Kingdom
    I have the same router, keep me posted with any updates.
  10. mykem macrumors regular

    May 20, 2008
    Try a different DNS. If at one point you've changed yours to Google Public DNS ( or and you're experiencing slow apps/media DL from App Store/iTunes Store, try and find another DNS. You don't necessarily have to resort back to the default DNS (by diabling manual DNS).

    I had the same problem using the Google DNS- it tested fast and reliable using Speedtest or general web browsing but crawled while DL apps and iTunes media. What I did was to find an alternative DNS:, It's now back to faster apps/media DL. (FYI: my router is an SMC D3GN on Rogers in Toronto)
  11. vidinoz, Dec 9, 2012
    Last edited: Dec 9, 2012

    vidinoz macrumors newbie

    Dec 2, 2012
    Well, I think the fix for me (seemingly) was overriding the networks on my phone by manually adding them.

    I opened my wifi settings and 'forgot' the current (2.4 GHz) network. Then, even though the phone picked it up again as it could see it, I manually added the 2.4GHz network again via the 'other' button and manually typing in the SSID, security type - pressed ok, then input the password when requested.

    What threw me though was that I didn't see an instant increase in speed. I tried downloading a previously bought 10MB app from the app store and it was just as sluggish - hence I wrote the 'fix' off as another fake.

    I even did a hard reset after applying the settings, and again, tried downloading the app and it was still sluggish.

    The following day I got back from my run and noticed there were app updates available. To my surprise I noticed they downloaded very quickly. The only difference was that I had no cover on my phone as I had just taken it out of my Belkin arm band... I was a little concerned for a couple of minutes that my regular phone cover had been the issue all along, so again, downloaded an app (the same one I always tried with) with the phone cover off and the DL speed was great.

    Next test - DL with same app again with the cover back on. So deleted the app, case back on the phone, DL the app again and the speed was fine.

    Next test, my 5GHz channel which I had not touched. DL the app again on the 5GHz channel and it was incredibly slow once more. So, I did the same as with the 2.4GHz channel and manually entered the settings. This time though the speed increase was instant.

    I'm still not entirely sure if this was the only fix that made the difference. I have made quite a few adjustments back end to the phone and the network. The wifi reception on the phone is still not amazing, but all speeds across the board are very quick now.

    Basically on the router IPv6 is still on, my QoS is off and I've manually set the phone to the network. I think they are the key things for my success.

    Good Luck. :cool:
  12. Risco macrumors 68000


    Jul 22, 2010
    United Kingdom
    Thanks, tried all that but no luck. I did however find an updated firmware that seems to improve things.
  13. vidinoz macrumors newbie

    Dec 2, 2012

    Being an inquisitive person, after the mammoth effort to 'fix' my connection issues I checked out the new FW for the router as you had found it helped.

    I'm running a WNDR3700v1 - and even though I tried searching on the router for the update, it never picked it up.

    After going to the Netgear site I did indeed see the new WNDR3700-V1.0.16.98 FW (Firmware) version and applied it (Backing up my settings first AND knowing that I had a spare identical router I'd un-bricked when someone else had tried putting custom FW on it (took 3 mins to un-brick and I scored a free router, nice - always wondered when it would come in handy)).

    I did this in the evening and didn't notice any immediate changes. I remote accessed into another computer to encode some files and all seemed fine until I go to work today. I could no longer access my NAS - either by DDNS or straight IP:port access from either a PC or my phone. I could not access my IP camera either.

    When I got home I tried accessing the NAS from my phone and all of the computers. Wired or wireless, it did not work - I could access the NAS folders that were mounted on my various machines no problem. Only my 'Synology Assistant' would log me in on a wired connection. I triple checked all of the settings and nothing was wrong. Re-booted the NAS, router, modem plus all of the other usual things you check first for errors (loose cables etc).

    So - long story short. I installed the settings onto the router with the older FW and after booting that up everything was back to normal.

    I will not be using the FW for the time being as there must be some serious Port Forward bugs... but, I expect to rule it out totally, I should apply the old settings to the router with the new FW and try that again to make sure it wasn't just something I'd missed. It's getting late so will try tomorrow and will update then.

    If anyone can advise if they have had the same issue with the FW please advise, that would be great.
  14. d23gas, Feb 1, 2013
    Last edited: Feb 1, 2013

    d23gas macrumors newbie

    Apr 25, 2009
    I'm having exactly the same issue as you. I'm in Uruguay have a FTTH 50Mbps Internet connection. YouTube and Apps in the iPhone 5 take forever. Vimeo too. They weird thing is that Speedtest works great, reaches almost my 50mbps. So, don't get what is wrong. My mom with 3G phone download apps instantaneously.

    Oh my router is Apple TimeCapsule last generation. 2TB.
  15. andyx3x macrumors 65816

    Mar 1, 2011
    I sold my 5 and repurchased the 4S just because of this issue.

    I put a 5 and a 4S side by side and could download 7-8 apps on the 4S before one would download on the 5. I could also download 5 or 6 songs on the 4S before one would download on the 5.
  16. Rocko1, Feb 1, 2013
    Last edited: Feb 1, 2013

    Rocko1 macrumors 68020


    Nov 3, 2011
    Exact issue here. Speedtest screams. All other things-apps, music, slow.

    On 40mbps LTE connection, it took 26 seconds to download a 40mb app.

    On a 10mbps Wifi connection it took 47 seconds to download the same 40mb app.
  17. Rocko1 macrumors 68020


    Nov 3, 2011
    Anyone find a fix for this? Seemed to only happen after the latest update.
  18. d23gas macrumors newbie

    Apr 25, 2009
    TCP Dump

    I've made a TCP Dump with Wireshark and a virtual interface of my iPhone 5 while downloading a 20MB app.

    It contains only some seconds of the download. The app took about 10 minutes to finish downloading.

    I'd really love if some engineer is able to understand the TCP Flow and if the errors that Wireshark shows could give us a clue of what is going on.

  19. Vitaminme macrumors newbie

    Sep 21, 2015
    Fixed!! I had same issue.

    Changed the router settings. Changed security mode from "WPA2 personal"to "WPA2/WPA MIXED PERSONAL"

    And changed network mode to wireless-A only.

    And selected random channel.
    You guys can try different settings.

    Now app store fast AF
    iphone 6

Share This Page