Slow wi-fi (especially 802.11g) with iPhone 3G

Discussion in 'iPhone Tips, Help and Troubleshooting' started by ludo2, Aug 7, 2008.

  1. ludo2 macrumors newbie

    Joined:
    Aug 7, 2008
    #1
    Hello,

    I have a problem with wi-fi on my iPhone 3G. While the phone normally joins my network (access point: Netgear WG602v3, firmware 1.2.5) and reports a good signal strength (3 bars), the connection is very slow. I have used tests like testmyiphone.com and the results are betweend 200 kb/s and 400 kb/s. Moreover, Youtube needs a very long time to buffer videos. My Macbook Pro is using the same access point without any of these problems.

    Now the interesting part: After setting the access point to 802.11b only, the iPhone works fine. As soon as I switch back to 802.11g only oder 802.11b/g combined the same problems occur.

    Things I have already tried:
    - Rebooting the iPhone
    - Rebooting the access point
    - Updating the iPhone to 2.0.1
    - Updating the access point to the latest firmware (1.2.5)
    - Restoring the iPhone
    - Disabling wi-fi encryption
    - Various channels to avoid interference
    - Different RTS threshold and fragmentention length settings
    But nothing helped.

    In addition, I tested my iPhone at a local T-Mobile hotspot (I am from Germany). While I obviously couldn't change the access point settings, I did not get better results anyway.

    Some users seem to have similar problems:
    http://forums.whirlpool.net.au/forum-replies-archive.cfm/1015942.html
    http://forums.whirlpool.net.au/forum-replies.cfm?t=956397&p=5
    http://www.youtube.com/watch?v=92oGshWbKGI

    Have you experienced similar problems with your iPhone 3G and 802.11g? Or is wi-fi working for you? Please let me know! Thanks for your help!
     
  2. ludo2 thread starter macrumors newbie

    Joined:
    Aug 7, 2008
    #2
    I have done further tests and discovered something even more interesting: Upload seems to work with full speed both with 802.11b and g. Moreover, my father's iPod touch shows exactly the same behavior. I am not sure if this a problem with
    - my access point
    - my iPhone and my father's iPod touch
    - the 2.0 software?
    As the problem occurs on both devices and nothing improved on the hotspot, a software error seems likely. But shouldn't more users have the same issue?
     
  3. brianj macrumors member

    Joined:
    Jun 5, 2007
    #3
    I had an unstable wifi connection. Couldnt connect even though it was the right pass...

    My wireless router is an apple extreme base station and I fixed the problems by changing channel and dissabling all ipv6 stuff on the router..Then it worked like a charm(No idea how this got enabled in the first place).
     

Share This Page