Slow WiFi on Haswell 15"

Discussion in 'MacBook Pro' started by zOlid, Oct 28, 2013.

  1. zOlid macrumors regular

    zOlid

    Joined:
    Jun 13, 2013
    #1
    I have the new 15" Haswell rMBP.
    But my wifi speeds are really slow compared to my other electronics.
    I have a ASUS AC66U router, and my HTPC that is running a 866mbit 2 antenna card is outperforming my rMBP by a lot.
    Some times my speed is as low as 25mbit out and in. While my HTPC gets up to 97mbit out and in. (100mbit maximum internet speed).
    Also when i move files from my NAS my HTPC moves it at around 25 megabytes/s.
    But my rMBP mostly caps out at a few megs...

    They are both in the same room.

    Im not that great at Macs yet since I'm new to them. But what can the issue be?
    And what can i try to fix it?
     
  2. daudi81 macrumors regular

    Joined:
    Oct 26, 2013
    #2
    Not sure how to fix it - but I've got the same exact router, with a new 15" just like you and speeds are great all over the house. 100mbit xfinity / comcast line and I haven't seen lower than 60mbit and that's with my router on the top floor and me being on the very bottom floor (3 floors, 7000 sq ft house). For comparison my ps3 on the same bottom floor rarely gets over 5-10mbit (horrible), so it's great. With the machine in the same room as the router, I'm seeing about 95mbit. My non AC devices can't break 50mbit (like my last gen iMac), so I think AC is working like it should. I know that didn't help you fix things, but at least you know it should be working better =)
     

Share This Page