Resolved Slow WiFi on Retina MacBook Pro

Discussion in 'MacBook Pro' started by Joe23, Jun 19, 2012.

  1. Joe23, Jun 19, 2012
    Last edited: Jun 19, 2012

    Joe23 macrumors 6502

    Joined:
    Sep 14, 2007
    #1
    Hi guys,

    Just got my new rMBP and I absolutely love it. However, since installing the various updates the WiFi speed has become ridiculously slow.

    When I downloaded the updates I was getting 1.8mb/s (the maximum speed for our internet connection in the office). Since the update I struggle to get higher than 300kb/s from a source I know will max out the connection here.

    I've tried turning on/off the WiFi, forgetting the wireless network and rejoining, rebooting and shutting down completely.

    Has anyone else experienced an issue? Perhaps it's not exclusive to the retina MBP.
     
  2. zachnelson macrumors 6502a

    Joined:
    Oct 23, 2010
    #2
    Updates can be crazy different in download speed.

    Download this file, its a test file from a CDN: http://cachefly.cachefly.net/100mb.test

    Tell me what that downloads at.
     
  3. Joe23 thread starter macrumors 6502

    Joined:
    Sep 14, 2007
    #3
    Failing to get over 100KB/sec. My MacBook Air (on the opposite side of me, same WiFi connection) is pulling that file in at over 1.2MB/s. Weird.
     
  4. zachnelson macrumors 6502a

    Joined:
    Oct 23, 2010
    #4
    Have you tried a restart,
    tried de-associating and re-associating with the network,
    tried power cycling the wireless access point?
     
  5. Joe23 thread starter macrumors 6502

    Joined:
    Sep 14, 2007
    #5
    I had previously tried all of those things. I had also tried setting up a different Location (after reading this post), to no avail.

    Weirdly, I just switched from my custom location back to 'Automatic' and I'm now able to download at what I would call 'normal' speed.

    I can only assume something, somewhere got confused. Thanks for your help though! :)
     
  6. nontroppo, Aug 8, 2012
    Last edited: Aug 8, 2012

    nontroppo macrumors 6502

    nontroppo

    Joined:
    Mar 11, 2009
    #6
    Note for those who stumble on this thread, you should also try turning OFF bluetooth.

    [​IMG]

    note although the signal:noise (dB) seems to improve, the network traffic shows much lower packets/sec using speedtest.net as the test down/upload site.

    Bluetooth can significantly interfere with wifi performance. I see drops from ~30Mbps to 0.5-3Mbps switching bluetooth on, only on my rMBP — my 2010 MBP sat next to it keeps a ~30Mbps download speed irrespectively. This is on an 802.11n netgear router.

    EDIT: as a slight aside, why doesn't Safari respect the dpi of my screenshot -- if I save the image it opens in Preview as expected, but embedded here it seems to be treated as a 72dpi image?
     

    Attached Files:

  7. nadjib1991 macrumors newbie

    Joined:
    Aug 13, 2012
    #7
    this is supposed to help

    I agree with nontroppo in his "Bluetooth signal noise" informational advice , but I also believe that the piece of info provided by Intel corp has a lot to do with any wireless receiver bundled alongside with a usb3.0 port in a laptop (rMBP in ur case).
    this is the link(read it carfully):http://www.intel.com/content/www/us...al-bus/usb3-frequency-interference-paper.html

    Hope this helps you figured it out...
     
  8. galenmd macrumors regular

    Joined:
    Sep 11, 2008
    #8
    OMG! Thanks for this info. I was getting AWEFUL speeds: 1 mbps, when my connection allows 20 mbps. Last night, I connected an Apple bluetooth mouse. I followed your suggestion and turned off Bluetooth. Immediately, my speed was restored.
     
  9. nontroppo macrumors 6502

    nontroppo

    Joined:
    Mar 11, 2009
    #9
    My fix for this was to get a 5GHz router, that way the bluetooth signal doesn't interfere with the 2.4GHz wireless...
     
  10. georgi0 macrumors regular

    georgi0

    Joined:
    Aug 21, 2006
    Location:
    Cyberspace
    #10

    where can we get this beautiful utility showing the bandwidth graphicaly?

    tnx
     
  11. lightz39 macrumors regular

    Joined:
    Nov 30, 2012
    #11
    So 5ghz works? I was planning on using it on my laptop anyways.
     
  12. nontroppo macrumors 6502

    nontroppo

    Joined:
    Mar 11, 2009
    #12
    Option (⌥) click on your wi-fi menu bar icon, select "Open Wi-fi Diagnostics..." and then press ⌘5 to open the bandwidth monitor :cool:

    ----------

    A 5GHz wifi router certainly doesn't interfere with bluetooth at all. I haven't really tested if this problem still affects 10.8.2, perhaps the bluetooth interference was fixed in some update after my last post here...
     
  13. rfurtado macrumors newbie

    Joined:
    Oct 14, 2011
    Location:
    North York, ON Canada
    #13
    Issue resolved for me

    ISP Provider: Bell Canada
    Internet Speed: Fibe 16 (16Mbps)
    Test performed: bell.ca/speedtest
    ----------------
    INITIAL TESTS:
    On Lenovo T420: 12Mbps (on wifi) / 16Mpbs (wired)
    On Macbook pro 13" mid 2009: 12Mbps
    On Macbook pro 13" Retina: 2Mbps
    ----------------
    FIX:
    1. Logged into the modem
    2. Accessed the Wireless configuration page
    3. Changed the channel from 6 to 10 and saved configuration
    ----------------
    RE-TESTS:
    On Lenovo T420: same speeds as before
    On Macbook pro 13" mid 2009: same speed as before
    On Macbook pro 13" Retina: IMPROVED to 12Mbps
     
  14. Iago macrumors newbie

    Joined:
    Oct 6, 2012
    #14
    This problem does affect 10.8.2

    I can't believe I have to buy a router if I want to use my Bluetooth apple keyboard AND use the internet at the same time. I use the keyboard and have the laptop up eye hight on a pile of books for ergonomic/posture reasons.

    The solution for me was to turn wifi off. I suppose I'll have to use a clunky keyboard. I'll test if this problem affects my computer when I'm running bootcamp win 7. I have a feeling it doesn't...
     
  15. MrMacMack macrumors 6502a

    Joined:
    Oct 24, 2012
    #15
    Wow, thanks for sharing that. That is very helpful!
     
  16. markofinsanity macrumors newbie

    Joined:
    Jan 19, 2014
    #16
    Also Try Selecting Channel, Don't Leave To 'Auto'

    I have a pretty fast connection using wired Ethernet (55mbps down, 10mbps up).

    But my 5GHz and 2GHz wireless n connections, which used to be almost as fast as wired, suddenly slowed down to 20-30mbps downstream.

    I tried using both 2.4GHz and 5GHZ.

    Despite being on 5GHz (which I settled on after the testing above), I then followed the suggestions in this thread to turn off Bluetooth (no effect, at least at 5GHz, as expected), as well as my Logitech keyboard, which has a 2.4GHz adapter in one of the USB ports on my mid-2012 MBP retina 15" -- again, no effect, as expected given the frequency difference.

    I then went through the tedious process of turning off 'auto channel select' and switching channels on my router (Asus RT-N66U), cycling between maybe 10 channels between 36 and 165 or thereabouts.

    While none of the channels was rock solid at 55mbps, I did find one that was consistently faster than the others, and set it to this channel.

    The downside is that I have to monitor speeds and channel selection. The router should be using auto mode to occasionally scan the wireless environment and do this for me. But, when I had finished my testing and tried one last time using auto, it selected a sub-optimal channel. (I don't know its selection algorithm.)

    Anyhow, this is a worthwhile process if you can't get speed up through other methods.

    And BTW, there are programs like InSSIDer that scan and report on the wireless environment in great detail. I just didn't think the time/cost tradeoff was worth it -- today. Maybe if it acts up with slow speeds again soon, I'll purchase it. We'll see.
     
  17. priitv8 macrumors 68020

    Joined:
    Jan 13, 2011
    Location:
    Estonia
    #17
    Actually, no need to buy anything. Mavericks does this out of the box. Even suggests what channels you should choose in your environment.
     
  18. AirThis macrumors 6502a

    Joined:
    Mar 6, 2012
    #18
    Over here it's ⌘2. :)
     
  19. Freyqq macrumors 68040

    Joined:
    Dec 13, 2004
    #19
    If this is your issue, it means that the 2.4 GHZ band (which bluetooth uses) is pretty crowded. If you use a router that has 5 GHZ, then you should not have this issue.
     
  20. krondek macrumors newbie

    Joined:
    Jun 17, 2014
    #20
    Bluetooth / Wifi Fix

    I've been struggling with this issue on my 2013 Retina MBP for months and finally a senior Applecare tech tech figured it out:

    This summarizes my problem:

    With bluetooth enabled, my wifi was VERY slow to connect (sometimes not at all), and my Internet speeds were as much as 60% slower.

    Delete the following file: Library > Preferences > com.apple.bluetooth.plist

    Restart your mac

    This seems to have fixed all my issues with wifi.
     

Share This Page