Slow WiFi

MTShipp

macrumors 6502a
Original poster
Mar 25, 2009
694
81
Raleigh, North Carolina
Wondering if others see similar performance described below?

I have a 400/20 cable Internet connection
I use Eero 2nd Gen for WiFi
On my new iPad Pro using a speediest, I avg 250/21
On my iPhone XsMax I avg 250/20
On my wife's iPhone 8, I avg 253/20

However, on my wife's iPad mini4, I avg 394/21

I've reset network settings and nothing changes.

Anyone see inconsistent speeds between iOS device models?

For comparison, my Windows and MacBook devices that are jacked in, I see 400/20 +/- 10/2
 

tps3443

macrumors 65816
Jan 24, 2019
1,301
833
NC,USA
Wondering if others see similar performance described below?

I have a 400/20 cable Internet connection
I use Eero 2nd Gen for WiFi
On my new iPad Pro using a speediest, I avg 250/21
On my iPhone XsMax I avg 250/20
On my wife's iPhone 8, I avg 253/20

However, on my wife's iPad mini4, I avg 394/21

I've reset network settings and nothing changes.

Anyone see inconsistent speeds between iOS device models?

For comparison, my Windows and MacBook devices that are jacked in, I see 400/20 +/- 10/2
I’m not to far from Raleigh, NC. Only a 25 minute drive for me. Cool to see someone local on here.

If you require ultimate latency and speed, try the usb-c to Ethernet adapter. I use it for PUBG sometimes.
 

ericwn

macrumors 68030
Apr 24, 2016
2,922
1,748
Sounds like your router doesn’t provide the same performance for newer devices than for older ones. Have you checked if the firmware is up to date?
 

MTShipp

macrumors 6502a
Original poster
Mar 25, 2009
694
81
Raleigh, North Carolina
Thanks for the reply folks but I think what I have discovered is the Eero management app is junk. If I disable cellular and BT on my I-devices and rerun the tests, the speeds show at ~400 which is expected. I think my speeds are correct but the app reports incorrectly.