Slow Windows 7 Gaming

Discussion in 'Windows, Linux & Others on the Mac' started by MyDesktopBroke, Jun 26, 2009.

  1. MyDesktopBroke macrumors 6502

    Joined:
    Jun 2, 2007
    #1
    I installed Windows 7 RC 64bit on my 2.53 Unibody late 2008 Macbook Pro with 4gb or ram, and thought I would try a game or two on it. On the OS X side, it runs Halo UB flawlessly even on the 9400 at highest settings (except AA), but on the Windows 7 side I installed Command and Conquer: Generals, and it slows to a slide show when I add 3 or more computer players. Graphics settings have no apparent effect on performance. The game runs perfect in 1 vs 1 matches on high, and is unplayable in 5 player or higher matches at lowest. The game is from 2003, and the requirements are minuscule:

    Hardware Requirements
    System: PIII 800 or equivalent
    RAM:128 MB RAM
    CD-ROM: 8X CD-ROM
    Video Memory: 32 MB VRAM
    Hard Drive Space: 1800 MB
    Mouse: Yes
    DirectX: DirectX v8.1

    Recommended System Requirements
    System: Pentium 4 1.0 Ghz or equivalent
    RAM: 256 MB RAM
    3D Sound Card: Yes

    I've run Windows Update, and downloaded all of them except the language packs and the tests updates. Gaming is not a priority for me, but I still want to know whats going with my computer.
     
  2. MKnight macrumors regular

    MKnight

    Joined:
    Oct 15, 2007
  3. Muncher macrumors 65816

    Muncher

    Joined:
    Apr 19, 2007
    Location:
    California
    #3
    It seems to be a networking issue? If the problem originates in the Windows 7 drivers, as more attention is focused on Windows 7 you should see an improvement. If it is coming from the game itself, perhaps some google searches might find a patch or workaround.
     
  4. MyDesktopBroke thread starter macrumors 6502

    Joined:
    Jun 2, 2007
    #4
    Yes, I already downloaded those drivers for the 9600, from two different places. When I first got the computer, I ran windows update and downloaded the drivers that were shown there. After I noticed the poor performance, I want directly to the Nvidia site, and downloaded from there. The only difference I saw was that the game no longer stretched to fit the full screen, so now I play with a boxed view.

    I also turned off Aero, and all of the windows 7 bells and whistles in the background, but it didn't help. A strange thing is that under XP, on my ancient Dell, I can run at low settings, but only notice slowdowns. On Windows 7, there is no slowdown, but instead there is breakup, like watching a slide show.

    And good luck finding an update for the game. It's EA. They drop support, like, a month after release.
     
  5. MKnight macrumors regular

    MKnight

    Joined:
    Oct 15, 2007
    #5
    Don't turn off Aero as that can reduce system stability...

    Aero uses the GPU and a totally different rendering method for all window drawing.

    Turning off Aero defaults to the old XP style GDI++ method which is all CPU driven and can be prone to locking up apps.


     
  6. bli625 macrumors 6502a

    bli625

    Joined:
    Mar 8, 2009
    #6
    Do you have your fans up? Your computer could be overheating.
     
  7. MyDesktopBroke thread starter macrumors 6502

    Joined:
    Jun 2, 2007
    #7
    No, it is still cool to the touch, even on the left speaker (which I think is where the GPU is).
     
  8. velocityg4 macrumors 68040

    velocityg4

    Joined:
    Dec 19, 2004
    Location:
    Georgia
    #8
    Possibly it is that the game uses DirectX 8.1. Perhaps it can not talk to the current Direct X in Windows 7 (10.1 I think).
     
  9. MyDesktopBroke thread starter macrumors 6502

    Joined:
    Jun 2, 2007
    #9
    When I check my version of DirectX (typing dxdiag in run), it says DirectX 11. Could I downgrade the version of DirectX I use?
    When I run the game on an older HP under XP, it runs smooth no matter what.
     
  10. Muncher macrumors 65816

    Muncher

    Joined:
    Apr 19, 2007
    Location:
    California
    #10
    You cannot downgrade your directx version I don't think, but it doesn't matter because you should have a copy of directx 9 on your computer which is backwards compatible.
     
  11. Gav Mack macrumors 68020

    Gav Mack

    Joined:
    Jun 15, 2008
    Location:
    Sagittarius A*
    #11
    Have you tried this patch?

    http://games.softpedia.com/get/Patch/Command-Conquer-Generals-Patch.shtml
     
  12. MyDesktopBroke thread starter macrumors 6502

    Joined:
    Jun 2, 2007
    #12
    I forgot to mention that I was using the expansion pack, Zero Hour. I have all the latest patches for that one.

    So how would I switch between them, or know which one is used for what (I'm not very knowledgeable in Windows, so I don't know if this makes sense at all)
     
  13. KevinN206 macrumors regular

    Joined:
    Jan 18, 2009
    #13
    The game will use whatever the game supports, so I will venture a guess and say 9. Also, Aero automatically disables itself when a fullscreen game is launched. You can keep Aero enabled without affecting your fullscreen games.
     
  14. Muncher macrumors 65816

    Muncher

    Joined:
    Apr 19, 2007
    Location:
    California
    #14
    I don't know alot about this either, as I have little experience with Vista and none with windows 7. IIRC, for Vista it should be a setting in the game. This game does not support DX10-11 at all, so it will run with DX9c every time. (DirectX 10+ are not backwards compatible with DirectX 9, so any game that does not support them defaults to DX9).
     
  15. MyDesktopBroke thread starter macrumors 6502

    Joined:
    Jun 2, 2007
    #15
    Thanks to everyone who offered help, but I found the problem.

    I realized I was running a version I had installed a third party mod. :rolleyes: When I turned this mod off, the game flew with max AI opponents on a large map at max graphics settings.
     

Share This Page