Slow Wireless after Update

Discussion in 'MacBook Pro' started by Stopsignguy, Aug 2, 2007.

  1. Stopsignguy macrumors member

    Joined:
    Jul 31, 2007
    Location:
    NJ
    #1
    I recently updated with the new Airport Express software update and noticed that my internet speeds are almost considerably slower. My internet startpage usually loads in 1-2 seconds pre-update now takes 6-7, sometimes more.

    Did anyone else experience this too?

    Also I used speedtest.net and got ~550 DL, ~40 UL, with sporadic ping. The first time i ran the test I got a ping of 470! The 2nd dropped down to 45 or so, and then a third around 80.

    I have Verizon DSL, and I remeber a while back when I performed the test of getting around ~760 DL, ~160 UL with a near constant ping of around 40.

    Any ideas?
     
  2. PimpDaddy macrumors 6502

    Joined:
    May 9, 2007
    #2
    My Airport seem to cause alot of timeouts on URL requests after the update. Also the connectivity seems to drop one mark at the airport icon in the top of the screen after about 1-2 hours of usage. It never did that before, and I'm using the MBP in the same places as before the update
     
  3. iBunny macrumors 65816

    Joined:
    Apr 15, 2004
    #3
    I have my MBP conntect wirelessly with my Airport Extreme-N Basestation and After all the updates, my internet connection accually seems much better. Espically large downloads via Torrent.
     
  4. aethelbert macrumors 601

    Joined:
    Jun 1, 2007
    Location:
    Chicago, IL, USA
    #4
    My connection seems to be much slower as well...
     
  5. PimpDaddy macrumors 6502

    Joined:
    May 9, 2007
    #5
    By the way, I use a Linksys WTRG 54 router(that's what I think it called)
     
  6. creator2456 macrumors 68000

    creator2456

    Joined:
    Jul 10, 2007
    Location:
    Chicago
    #6
    I am using an Airport Extreme and I have noticed that at times my connection drops to about 70% for 5 minutes or so every couple hours.

    Not a big deal, but annoying.
     
  7. jackiecanev2 macrumors 65816

    jackiecanev2

    Joined:
    Jul 6, 2007
    #7
    I'm having the same problem. My connection is intermittent, and sometimes my airport doesn't see my router at all. When it does, the connection is hideously slow. My PC isn't having a problem with the router at all wirelessly, nor is my desktop. :( My connection freezes completely with I open a torrent of any kind, and I have to reset the computer and the router.

    Does anyone know how to roll back the update??

    I have the Linksys WRT54G.
     
  8. Stopsignguy thread starter macrumors member

    Joined:
    Jul 31, 2007
    Location:
    NJ
    #8
    I tried the internet in Windows through Bootcamp, and its pretty much just as slow. Does that mean Apple broke something in the hardware (not physically but how it handles connections I guess)?

    I think it may only relate to 802.11g connections because I doubt think the faster n has this problem.

    Also, like I said before, the speed test DL/UL is still relatively high but when I'm browsing in OSX and look at the iStat widget, it shows the "In" section of the network part as downloading at around 4-6kbs when loading a website. After a bit of time browsing, I saw that the Total In was 14MB and the Total Out as 6MB; which as far as I know is a bad ratio when merely browsing the web.

    Hope this gets fixed...
     
  9. Ride9650 macrumors 6502

    Joined:
    Jun 29, 2007
    #9
    did you guys try verifying/repairing permissions? Mine browser speed got cut drastically too after the update, but after correcting the permissions, i was back to normal in about 5 min.
     
  10. xpovos macrumors 6502a

    xpovos

    Joined:
    Jun 7, 2007
    Location:
    Tennessee
    #10
    Slow connection speed isn't the only issue this bad update has introduced. I posted earlier about the latest security update causing USB audio recording problems on my SR MBP. I was wrong. I have now confirmed that the problem is the Airport update. I didn't see it before because it seems like a ridiculous connection to make. With all other updates installed, when recording (on battery power only) with AirPort turned off, I get consistent, clean audio. Turning Airport back on gives a clean first recording, but horrible static on subsequent recordings---until I turn it back off, after which I can make dozens of consistently clean recordings. Turn it on, static. And so on.

    The only downside is that correctly troubleshooting this issue has taken up most of a day of my time.
     
  11. AHDuke99 macrumors 68020

    AHDuke99

    Joined:
    Nov 14, 2002
    Location:
    Charleston, SC
    #11
    actually browsing has been slow for me as well. i dont really know why. i feel like i'm on a slower connection. downloading is still pretty quick, but web surfing is definitely slow. apple has been releasing sh*tty updates recently.
     
  12. MacPossum macrumors 6502

    MacPossum

    Joined:
    Jul 15, 2007
    #12
    My connection seems to be the same. It's all in your head!
     
  13. Stopsignguy thread starter macrumors member

    Joined:
    Jul 31, 2007
    Location:
    NJ
    #13
    Not with the speed differences I saw (look at my earlier posts).

    Also I have tried verifying permissions, as well as PRAM, and even Hardware Check, but to no avail.

    As AHDuke said, downloading speed seems to be normal but regular browsing speed is slow; does anyone know why this could be?

    Also can you guys post what model laptops you guys have; since the Macbook has supposedly better Airport reception than the MBP, I want to narrow down the problem.
     
  14. CusAndre macrumors newbie

    Joined:
    Aug 5, 2007
    #14
    I have a similar problem. Recently (first noticed yesterday) my MacBook Pro gets a short time of connectivity via the airport card before its display drops to 3 bars and the connection is gone. I have to restart airport and any apps that are connected to the internet to get connectivity back. Connecting via ethernet is fine. OS is 10.4.10. AE firmware is 1.1.9.3

    We also have a powerbook and I've not been able to replicate there.

    Anyone know how to roll back an airport update?
     
  15. jackiecanev2 macrumors 65816

    jackiecanev2

    Joined:
    Jul 6, 2007
    #15
    Apparently there is no such thing as a "roll-back;" apple's version of such a thing is called "reinstall your OS."

    :eek::(
     
  16. steve31 macrumors 6502a

    steve31

    Joined:
    Jul 20, 2007
    Location:
    Edmonton Canada
    #16
    I have noticed slower speeds as well. Apple needs to fix this.:(
     
  17. neetster macrumors newbie

    Joined:
    Jul 21, 2007
    #17
    My macbook pro has always been much slower than my pc in terms of surfing the web and downloading. Downloading large files takes many days on my macbook pro and it's gotten to the point where it takes over 1 minute to load a flash encoded video from sites such as youtube. Not 1 minute to load the whole video, but 1 minute to just actually see a picture on the screen.

    Edit: By the way, posting this message on this page took around 8 or 9 seconds. I'm using 2wire.
     
  18. giganten macrumors 6502a

    Joined:
    Jan 23, 2006
    #18
    Yeah my internet connection does the same drops to 3 and then gone. If i turn my Airport Extreme off and then turn it on again i get my connection back.
     
  19. mccoyboy2 macrumors newbie

    Joined:
    Aug 7, 2007
    #19
    Ahh!!!!!!

    OMG. My Macbook Pro is doing the same thing. The wireless internet is sooooooooooooo slow, just recently.
    It's fine with ethernet.
     
  20. zepharus macrumors 6502a

    zepharus

    Joined:
    Aug 7, 2007
    #20
    I noticed the SAME issue drectly after the update

    I was pissed and thought my router might be going.. but upon investigaton noticed it wasnt my PCs at all, just my MBP.

    I updated the FIRMWARE on my DGL-4300 (D-Link GamerLounge) Router and that has made the issue 90% better.

    I say 90% becasue before I was losing connection every 3-5 minutes an getting PISSED. Every time i lost connection, I noticed the airport icon lose ONE bar. It was like clockwork.

    It now stays contstand 90% of the time. during an evening of browsing I might lose coneection once .. but only for a short period of time.

    Try a firmware upgrade.
     
  21. jonnymacinc macrumors newbie

    Joined:
    Aug 12, 2007
    #21
    normal download but slow browsing

    My download speeds are normal too but my browsing is WAY slower!
    pages just freeze and I have to reload. sometimes after 2 or 3 reloads, it loads just fine.
     
  22. bigg black macrumors newbie

    Joined:
    Mar 4, 2007
    #22
    wow im not the only one. at first i thought it was the router but now it dose seem to be the update.
    How long do you think before apple fixes this?
     
  23. maclover007 macrumors member

    Joined:
    Jul 13, 2007
    Location:
    USA
    #23
    same here....i am starting 2 get very annoyed. they better fix it:mad:
     
  24. Joshua8o8 macrumors 6502

    Joined:
    Jul 2, 2007
    Location:
    Honolulu, Hawai'i
    #24
    i have the exact same problems! But im on a macbook. What happened?
     

Share This Page