slow wireless, other computers fine

Discussion in 'Mac Accessories' started by Thanatoast, Jul 11, 2007.

  1. Thanatoast macrumors 6502a

    Thanatoast

    Joined:
    Dec 3, 2002
    Location:
    Denver
    #1
    I have a 17" iMac I bought in November of last year that is cursed with slow wireless speeds.

    Downloading an HD trailer off of Apple's website, side-by-side with my fianceé's Macbook results in her mac completing the download three times faster than my own. So I know it's not my cable modem or my Airport Express, because my fianceé doesn't have the slowness issue.

    It must be something on my computer, but what? I tried enabling interface robustness, setting the multicast rate higher, and switching the Airport Express to G-only but to no avail.

    Can anyone help? :(
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    Try changing the broadcast channel. Different channels have different luck with reception in various spots within their broadcast radius, depending on what interference yuo may be getting. :)
     
  3. kevinliu4 macrumors regular

    Joined:
    Aug 8, 2006
    #3
    i have seen this solution proposed several times. can anyone actually explain how ones goes about changing the channel?!
     
  4. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #4
    Well it's a router settings so it's slightly different for each brand. Using an AirPort Express like Thanatoast's, it is done through the AirPort Admin Utility. It is a drop down list at the bottom of the AirPort page. Try it at each extreme setting (channel 1, or channel 11) and then try it in the middle (channel 6 or so). :)
     

Share This Page