Sluggish Dialogues

Discussion in 'MacBook Pro' started by deathcells, Dec 1, 2014.

  1. deathcells macrumors newbie

    Joined:
    Nov 27, 2014
    #1
    Hello All

    Please excuse me if i posted in the incorrect place, very new to forums and brand new here.
    I have just upgraded to Yosemite as i bought a OWC Data Doubler type setup and installed myself into my 2011 Macbook Pro (2.2GHz , 16G RAM).
    I thought it fitting to give the new SSD a fresh install of the latest OS.
    Im not sure if it is important to note that i left my original drive (750HDD) in its bay and put the new Yosemite running SSD into the data doubler cradle now occupying the optical bay. I have read that some people reverse this.

    After fixing a few hiccups, ie: startup disk priority, kext signing/ trimm issue, restoring all my files and apps, etc... i got everything running relatively smoothly.
    However, the one thing eating away at me is most (but what seems to be ALL) dialogue boxes. Whenever i need to save/ open from within an app, OSX will beachball and then only load the dialogue box after about a full minute.
    I use text edit frequently and even on snowleopard it was super quick and snappy, which is exactly why it was my go-to for anything i needed done quickly with text. Now it hangs on launch exactly the same way the dialogues are and if i want to save then it will hang as per desrc above...

    I am suspicious that it is because finder needs to read my old HDD?? but i cant figure out why that would cause such a big lag and beachball. I even made sure i had no network connections on to test the speeds. and TRIM is on and as far as i can tell, operational.

    Any suggestions from you wise fellows would be overly appreciated!!

    Cheers for now,
     
  2. domain macrumors member

    Joined:
    Jan 25, 2007
    #2
    This *could* be related to your issue... per OWC's own product page:

     
  3. deathcells thread starter macrumors newbie

    Joined:
    Nov 27, 2014
    #3
    Thanks, Domain.
    That is interesting.
    I did not purchase a kit from OWC i gathered components on my own so im not sure if my drive is 6G or 3G. is there anyway to tell from this system report on that drive:

    Macintosh SSD:

    Available: 307,13 GB (307*130*105*856 bytes)
    Capacity: 510,88 GB (510*879*203*328 bytes)
    Mount Point: /
    File System: Journaled HFS+
    Writable: Yes
    Ignore Ownership: No
    BSD Name: disk1
    Volume UUID: AA7A6B20-4F20-3E58-BD9A-6974EF25CFAF
    Logical Volume:
    Revertible: Yes (no decryption required)
    Encrypted: No
    LV UUID: 818779C9-177A-404A-B9B2-D3400FDEC814
    Logical Volume Group:
    Name: Macintosh SSD
    Size: 511,25 GB (511*250*432*000 bytes)
    Free Space: 18,9 MB (18*907*136 bytes)
    LVG UUID: 2D68F869-501E-44F4-8F04-3C729894D55E
    Physical Volumes:
    disk0s2:
    Media Name: TS512GSSD320 Media
    Size: 511,25 GB (511*250*432*000 bytes)
    Medium Type: SSD
    Protocol: SATA
    Internal: Yes
    Partition Map Type: GPT (GUID Partition Table)
    Status: Online
    S.M.A.R.T. Status: Verified
    PV UUID: 8D98FB0B-AFB6-49BF-869D-4816F9EDF0F0
     
  4. domain macrumors member

    Joined:
    Jan 25, 2007
    #4
    According to the manufacturer specs (Transcend) that is a Sata3 6GB/s drive, so it might be an issue as OWC has noted... you could try to swap the drive locations to be 100% for sure.
     
  5. deathcells thread starter macrumors newbie

    Joined:
    Nov 27, 2014
    #5
    Ok i will give it a try and report back.

    Thanks so much for your help, Domain!
     
  6. deathcells thread starter macrumors newbie

    Joined:
    Nov 27, 2014
    #6
    Hey Domain

    I tried that but unfortunately it has now thrown my OS into some kind of kernel panick and I get the DO NOT PASS or prohibitory sign at start up. I cleaned PRam and SMC. Booted into recovery and did repair disk and repair permissions on both drives. I cannot, however, boot into safe mode or single user mode. It just hits kernel panic again even if I use shift cmd v when booting.
    I have a time machine but it was unplugged for the last week. *facepalm*

    A bit painful to say the least but I can wait until tomorrow otherwise I have to reinstall. If you have any tricks you think I could try or anyone reading this knows a method to get back into yesterday's OS that would be awesome!

    Many thanks in advance!
     
  7. deathcells thread starter macrumors newbie

    Joined:
    Nov 27, 2014
    #7
    Hi Domain/ anyone else

    I managed to eliminate the problem in my last post. i had to turn off kext signing as i have a third party ssd.
    However, switching my drives around has not solved my original issue. All save/open dialogues still lag and alot of apps hang on launch. yes even Textedit :(

    Any help is greatly appreciated.

    Cheeers!!
     
  8. domain macrumors member

    Joined:
    Jan 25, 2007
    #8
    Well if that wasn't the issue, then I am not sure.

    In Mavericks some people were having issues with open/save dialogs hanging due to the automounter trying to mount network drives... but I don't know if this applies to Yosemite since I refuse to upgrade.

    One "workaround" in Mavericks was to do the following:

    sudo vi /etc/auto_master
    Comment out the line that starts with "/net"
    sudo automount -vc
    Check to see if problem persists.

    Again I have no ideal if this applies to Yosemite at all, so just a wild shot in the dark... and if you are also having problems launching applications it may not be related.
     
  9. deathcells thread starter macrumors newbie

    Joined:
    Nov 27, 2014
    #9
    Thanks, Domain.
    I think i will hang tight for now, dont like playing with sudo unless its assured to work. perhaps someone else will have another idea. i really appreciate the input regardless and the time you have taken to try help!

    have a great day!
     
  10. poiihy macrumors 68020

    poiihy

    Joined:
    Aug 22, 2014
    #10
    If it has something to do with the hard disk, you can unmount the hard disk and see if it still happens. Go in Disk Utility, select a/the volume in your hard disk, and click unmount. Repeat for all other partitions on the hard disk, if any.

    This way the system will have no access to the hard disk's partition, it would just be completely disconnected and the system will not mess with it.

    To remount volumes just select and click mount.
     
  11. deathcells thread starter macrumors newbie

    Joined:
    Nov 27, 2014
    #11
    Hi Poiihy!

    Thanks for the suggestion. Very interesting, cant believe i didnt think of that.
    Well, i tried it and of course the dialogues still hang so that seems to mean the problem is not the communication between SSD & HDD.
    Perhaps it's some other buggy Yosemite thing regarding 3rd party SSD....

    Thanks !!
     
  12. domain macrumors member

    Joined:
    Jan 25, 2007
    #12
    The sudo command is essentially the same as when you are prompted for a password for "Administrator" type access when changing items in System Settings etc. That said if you are not familiar with the *NIX internals/not comfortable with the command-line then it may not be an option.

    Trying to unmounts the HDD was something I should have though of as well... you might also try to disable the "put hard disks to sleep" option in Energy Saver to see if that has any impact.

    You could potentially try (if you haven't already)... remove any external devices (USB/Firewire/etc.), disconnect from any network shares, and disable all of your network connections (Wireless/Ethernet/etc.)... that would in theory cause the automounter to stop trying to load network shares (if that is indeed the issue).
     
  13. deathcells thread starter macrumors newbie

    Joined:
    Nov 27, 2014
    #13
    Hi Domain

    Thanks again for the response. That hdd sleep function has been off since the getgo. never liked the idea of it.
    I tried the sudo command you originally posted to disable auto mount and when i got in, the /net had already been commented out. So i obviously tried that a month or so back during my initial troubleshooting phase to no avail. This is really beginning to baffle me and im sure you guys too!!
    I have also tried the peripheral free boot and its all the same.. i wonder if it isnt just Yosemite hating this SSD...

    Cheers for now
     

Share This Page