Sluggish intel iMac 24" (HD problem?)

Discussion in 'Mac Basics and Help' started by TheDesmodus, Jun 23, 2008.

  1. TheDesmodus macrumors newbie

    Joined:
    Jun 23, 2008
    #1
    Hi,

    I am having several problems with my 1st gen Intel iMac 24". The first I started to notice was that last year, it seemed to become slower and slower. Then when 10.5 came out, I reformatted and did a clean install.
    But still the machine felt sluggish to me. Not instantly giving me the content of a window when double clicking, but taking a few seconds before showing. Also when performing multiple tasks quickly after one another it seems to wait for a previous one to finish before it starts with the next one (maybe I am too fast, but it is highly annoying when you are trying to move an icon, and have to wait 5 seconds to then see it jumping around the screen).
    Another thing that lately appeared are horizontal lines on my screen, that can be captured in a screenshot:
    http://www.hofhuis.org/meuk/scherm.png

    As you can see it does not go all the way over the screen, and I can place things over it. So that part seems like a system bug to me (?).

    But about the sluggish speed.. anyone any idea? I ran Drive Genius over it and no errors came up... will it help to put in a Raptor? Oh, I have 2Gb of memory in it.
     
  2. misterredman macrumors 6502a

    misterredman

    Joined:
    Oct 3, 2007
    #2
    Did you try the diagnostics that came with your mac? You know to be sure you don't have an hardware problem not related with the HD.
     

Share This Page